Do I need to enable TRIM support on a iMac

Hey Guys,

So I’ve had this old iMac 27" mid-2011 that suffered from the apparently typical hardware problem of a failed graphics chip due to sub-standard solder, i.e. it didn’t contain lead… Needless to say, I’ve been using it to put post-it pads on.

I believe I’ve disabled the graphics chip with a nvram command and running on the integrated chip. I’ve booted Fedora 35 successfully and, as a matter of fact, it’s fantastic even without the graphics acceleration! I’ve not tested everything but I’ve not run into any problems.

However, I do have some questions:

  1. I have a SSD, do I need to add ‘discard’ to the fstab file? I did try this and the system crashed!
  2. Some Mac ‘genius’ fudged one of my temperature sensors and I need to manually control the fan. I did do a search and a command line tool is available but is their a GUI.

Thanks guys.

Found this for the fan issue:
lm_sensors - Hardware monitoring tools
xsensors - An X11 interface to lm_sensors
ksensors - KDE frontend to lm_sensors
hopefully this will solve it.

No need. there is a periodic fstrim systemd timer.



is the binary you will need to control the fans.
It’s for laptops but apparently you can use it for desktops as well!
You’ll have to identify the correct fan number from /sys/device/platform/applesmc.768
After adding/changing the variables in /etc/mbpfan.conf, you’ll need to restart the service with:
sudo systemctl restart mbpfan.service

Thanks Arun,
This simplifies things even more.
Fedora is giving Apple a run for it’s OS!
Can’t recommend this OS enough!

Thanks again Arun!

Fedora does indeed execute fstrim automatically by default on a weekly basis.

check with:
sudo systemctl status fstrim.timer

If you want to change it to execute on a daily basis change this:


@asgr71 what nvram command was that, that you used to disable the graphics chip…?

Hi Anton,

This is the site…

You should not edit this file as it’s owned by the package manager. Use systemctl edit fstrim.timer to open an override file and edit that instead.