DNF update failed / Skype GPG key expired

Good afternoon, dear colleagues. Where am I wrong?

[root@hard ~]# dnf clean packages
50 files removed
[root@hard ~]#
[root@hard ~]# LANG=C; dnf clean all; dnf makecache; dnf update

(40/49): samba-dc-provision-4.18.2-0.fc38.noarch.rpm 5.0 MB/s | 393 kB 00:00
(41/49): samba-ldb-ldap-modules-4.18.2-0.fc38.x86_64.rpm 2.0 MB/s | 37 kB 00:00
(42/49): samba-libs-4.18.2-0.fc38.x86_64.rpm 6.2 MB/s | 138 kB 00:00
(43/49): samba-tools-4.18.2-0.fc38.x86_64.rpm 1.7 MB/s | 29 kB 00:00
(44/49): samba-dcerpc-4.18.2-0.fc38.x86_64.rpm 7.6 MB/s | 761 kB 00:00
(45/49): samba-winbind-modules-4.18.2-0.fc38.x86_64.rpm 4.0 MB/s | 71 kB 00:00
(46/49): llvm-libs-16.0.1-1.fc38.x86_64.rpm 12 MB/s | 27 MB 00:02
(47/49): samba-winbind-4.18.2-0.fc38.x86_64.rpm 1.2 MB/s | 451 kB 00:00
(48/49): spirv-llvm-translator-16.0.0-2.fc38.x86_64.rpm 2.4 MB/s | 839 kB 00:00
(49/49): skypeforlinux_8.97.0.203-1.x86_64.rpm 34 MB/s | 119 MB 00:03
/var/cache/dnf/updates-b7ba662710b98f1a/packages/kernel-devel-6.2.11-300.fc38_6.2.12-300.fc38.x86_64.drpm: md5 mismatch of result
Some packages were not downloaded. Retrying.
kernel-devel-6.2.12-300.fc38.x86_64.rpm 22 MB/s | 19 MB 00:00

Total 29 MB/s | 390 MB 00:13
Failed Delta RPMs increased 385.4 MB of updates to 390.0 MB (1.2% wasted)
skype (stable) 5.6 kB/s | 1.7 kB 00:00
GPG key at https://repo.skype.com/data/SKYPE-GPG-KEY (0xDF7587C3) is already installed
The GPG keys listed for the “skype (stable)” repository are already installed but they are not correct for this package.
Check that the correct key URLs are configured for this repository… Failing package is: skypeforlinux-
GPG Keys are configured as: https://repo.skype.com/data/SKYPE-GPG-KEY
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.
Error: GPG check FAILED
[root@hard ~]#

You are facing

Easiest workaround is to remove skype, remove skype repo, and install it as flatpak from flathub

1 Like

Skype have issued a new GPG key:

sudo rpm --import https://repo.skype.com/data/SKYPE-GPG-KEY

I had to go further.
I deleted the skype repo
rm /etc/yum.repos.d/skype-stable.repo
then got the skype key
rpm -qa gpg-pubkey --qf "gpg-pubkey-%{version}-%{release} %{summary}\n"
which was
and removed it
rpm -e gpg-pubkey-df7587c3-576a5c23
and then added the repo again
curl -o /etc/yum.repos.d/skype-stable.repo https://repo.skype.com/rpm/stable/skype-stable.repo
and finally updated skype, which now prompts me to accept the key again and finished successfully
dnf clean all; dnf update skypeforlinux


@uriesk 's method worked for me as well, except there was no need to delete the skype repo and re-add it. Just removing the old gpg key and re-running update was sufficient:

rpm -e gpg-pubkey-df7587c3-576a5c23
dnf update skypeforlinux

Thanks, it works.

Thanks, it works.

And rpm -qa gpg-pubkey reminds me that I need to clean many old gpg pubkeys, starting from Fedora 19.

Removing the .repo file is now a problem because Microsoft quit creating the skype-stable,repo file.
I obtained a replacement that works from the Internet archive:

name=Skypeforlinux - stable

@rocketraman The shorter solution you provided worked well for me.

Thank you!!!

FYI - that left me with:
1 package skipped:

It’s a proprietary codec for bluetooth and part of the media download from RPMFusion–something I don’t use.


Installing Skype on Fedora :: Fedora Docs