DNF Rollback Failed (nvidia rpm fusion)

My previous config:
Fedora 37 on Wayland
Kernel: 6.3.12
Nvidia 3050 on 530.41.03 drivers

Had some time today and decided to try the latest 535 drivers with the latest 6.4.* kernel. It did not go well and decided to DNF rollback. I got the following error on rollback.

Error: The following problems occurred while running a transaction: Cannot find rpm nevra "kmod-nvidia-6.3.12-100.fc37.x86_64-3:530.41.03-1.fc37.x86_64".

I have previously managed to rollback between prior nvidia driver versions, so this is new to me.

I then tried to downgrade, however it downgraded me to the 520 drivers.
sudo akmods is failing on a separate issue (would prefer to try to troubleshoot back to 530 drivers first).
nvidia-smi returns “NVIDIA-SMI has failed because it couldn’t communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.”
Wayland boots to a blank screen, and I’m forced to use X11 now.

I am way over my head on this and am asking for step by step guidance on how to troubleshoot this. I wish to get back to the 530 drivers, with a working nvidia-smi and back on Wayland.

It seems that the 530 drivers have vanished from the rpm fusion non-free repo.
I have tried looking for some sort of archived 530 drivers in Koji or some other repo but with no success.

I’m aware that rpm fusion is a separate thing from Fedora, but any help or clue in the right direction is appreciated. Thank you

Check if the required package version is still in the repos:

sudo dnf --showduplicates list package_name

If not, then you need to download and install it manually:

1 Like

Thanks for the reply, somehow I could not find the required packages from the search bar.
Anyways, here are the relevant links


I needed the following packages:

xorg-x11-drv-nvidia-cuda-libs (i686)       
xorg-x11-drv-nvidia-cuda-libs (x86_64)
xorg-x11-drv-nvidia-libs (i686)
xorg-x11-drv-nvidia-libs (x86_64)

I then ran sudo akmods to ensure the drivers were built against the kernel.

I’m now back to my prior config. Thanks again for the help.