Dnf not showing most of negativo17 packages in F34

, ,

for some reason dnf list all *nvidia* is showing:

Installed packages
dkms-nvidia.x86_64                         3:465.19.01-1.fc34  @fedora-nvidia                     
kmod-nvidia-5.11.13-300.fc34.x86_64.x86_64 3:465.19.01-1.fc34  @@commandline                      
kmod-nvidia-5.11.14-300.fc34.x86_64.x86_64 3:465.19.01-1.fc34  @@commandline                      
nvidia-driver.x86_64                       3:465.19.01-1.fc34  @fedora-nvidia                     
nvidia-driver-NVML.x86_64                  3:465.19.01-2.fc33  @cuda-fedora33-x86_64              
nvidia-driver-cuda.x86_64                  3:465.19.01-2.fc33  @cuda-fedora33-x86_64              
nvidia-driver-cuda-libs.x86_64             3:465.19.01-2.fc33  @cuda-fedora33-x86_64              
nvidia-driver-libs.x86_64                  3:465.19.01-2.fc33  @cuda-fedora33-x86_64              
nvidia-kmod-common.x86_64                  3:465.19.01-3.fc33  @cuda-fedora33-x86_64              
nvidia-libXNVCtrl.x86_64                   3:465.19.01-1.fc34  @fedora-nvidia                     
nvidia-modprobe.x86_64                     3:465.19.01-1.fc33  @cuda-fedora33-x86_64              
nvidia-persistenced.x86_64                 3:465.19.01-1.fc34  @fedora-nvidia                     
nvidia-settings.x86_64                     3:465.19.01-1.fc34  @fedora-nvidia                     
xorg-x11-drv-nvidia-kmodsrc.x86_64         3:465.31-1.fc34     @rpmfusion-nonfree-updates-testing

Available packages
akmod-nvidia.x86_64                        3:465.31-1.fc34     fedora-nvidia                      
akmod-nvidia.x86_64                        3:465.31-1.fc34     rpmfusion-nonfree-updates          
akmod-nvidia-340xx.x86_64                  1:340.108-11.fc34   rpmfusion-nonfree                  
akmod-nvidia-390xx.x86_64                  3:390.143-1.fc34    rpmfusion-nonfree                  
dkms-nvidia.x86_64                         3:465.31-1.fc34     fedora-nvidia                      
kmod-nvidia.x86_64                         3:465.31-1.fc34     fedora-nvidia                      
kmod-nvidia.x86_64                         3:465.31-1.fc34     rpmfusion-nonfree-updates          
kmod-nvidia-340xx.x86_64                   1:340.108-11.fc34   rpmfusion-nonfree                  
kmod-nvidia-390xx.x86_64                   3:390.143-1.fc34    rpmfusion-nonfree                  
nvidia-query-resource-opengl.x86_64        1.0.0-10.fc34       fedora                             
nvidia-query-resource-opengl-lib.i686      1.0.0-10.fc34       fedora                             
nvidia-query-resource-opengl-lib.x86_64    1.0.0-10.fc34       fedora                             
nvidia-sdk-optix.noarch                    7.1.0-1.fc34        fedora-nvidia                      
nvidia-sdk-optix-samples.noarch            7.1.0-1.fc34        fedora-nvidia                      
nvidia-sdk-video-codec.noarch              1:10.0.26-2.fc34    fedora-nvidia                      
nvidia-sdk-video-codec-samples.noarch      1:10.0.26-2.fc34    fedora-nvidia                      
nvidia-settings-390xx.x86_64               390.143-1.fc34      rpmfusion-nonfree                  
nvidia-texture-tools.i686                  2.1.2-1.fc34        fedora                             
nvidia-texture-tools.i686                  2.1.2-1.fc34        updates-testing                    
nvidia-texture-tools.x86_64                2.1.2-1.fc34        fedora                             
nvidia-texture-tools.x86_64                2.1.2-1.fc34        updates-testing                    
nvidia-texture-tools-devel.i686            2.1.2-1.fc34        fedora                             
nvidia-texture-tools-devel.i686            2.1.2-1.fc34        updates-testing                    
nvidia-texture-tools-devel.x86_64          2.1.2-1.fc34        fedora                             
nvidia-texture-tools-devel.x86_64          2.1.2-1.fc34        updates-testing                    
pcp-pmda-nvidia-gpu.x86_64                 5.3.1-1.fc34        updates                            
xorg-x11-drv-nvidia-340xx.x86_64           1:340.108-5.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-340xx-devel.i686       1:340.108-5.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-340xx-devel.x86_64     1:340.108-5.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-340xx-kmodsrc.x86_64   1:340.108-5.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-340xx-libs.i686        1:340.108-5.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-340xx-libs.x86_64      1:340.108-5.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-390xx.x86_64           3:390.143-2.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-390xx-cuda-libs.i686   3:390.143-2.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-390xx-cuda-libs.x86_64 3:390.143-2.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-390xx-devel.i686       3:390.143-2.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-390xx-devel.x86_64     3:390.143-2.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-390xx-kmodsrc.x86_64   3:390.143-2.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-390xx-libs.i686        3:390.143-2.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-390xx-libs.x86_64      3:390.143-2.fc34    rpmfusion-nonfree                  
xorg-x11-drv-nvidia-cuda-libs.i686         3:465.31-1.fc34     rpmfusion-nonfree-updates          
xorg-x11-drv-nvidia-cuda-libs.x86_64       3:465.31-1.fc34     rpmfusion-nonfree-updates          
xorg-x11-drv-nvidia-libs.i686              3:465.31-1.fc34     rpmfusion-nonfree-updates          
xorg-x11-drv-nvidia-libs.x86_64            3:465.31-1.fc34     rpmfusion-nonfree-updates

my negativo 17 repo is:

name=negativo17 - Nvidia

name=negativo17 - Nvidia - Source

but as is visible in https://negativo17.org/repos/nvidia/fedora-34/x86_64/ a lot of packages and updates are missing in the list. Any clue why dnf cannot get up to date with the repo?

As far as I know in order to show all of negativo’s packages you would need to have the multimedia repo enabled instead of the nvidia repo.Unless it has changed I haven’t used it in awhile you can not have rpmfusion and negativo enabled at the same time as they will conflict and negativo will not over ride rpmfusion.


Hum, by what I know fedora-nvidia is not dependent of fedora-multimedia. I’m a bit confused because there is a comment by the maintainer pointing only fedora-multimidia is not compatible as stated here:

Nvidia packages are just conflicting with the RPMFusion ones, while the multimedia repository is not compatible at all with RPMFusion.

Aparently there is a way to set priority or resolving the conflicts between RPMFusion and negativo17? Would be nice because I need Virtualbox.


From what I see there you have conflicting repos enabled.

several packages show in more than one repo and that leads to problems, if not now then later.

Personally I would suggest you clean up the repo that are enabled and only use the one(s) that are stable. I only use the regular fedora, updates, and the rpmfusion repos and don’t see the mess you displayed there.

1 Like

I’m trying to move to negativo17 because it is more complete for CUDA and tensorflow, but you’re right, I will clean it, and see if it gets sane.

DNF lists only the latest package versions unless you specify the --showduplicates option.
So packages with the same name but older versions are hidden by default.
You can also customize the priority setting to prefer some repo over the others.

1 Like

Still pretty much confused, don’t know what is going wrong: :thinking:

sudo dnf repolist enabled
irepo id                                                                                                        repo name
anydesk                                                                                                         AnyDesk Fedora - stable
code                                                                                                            Visual Studio Code
copr:copr.fedorainfracloud.org:wanzenbug:firefox-nightly                                                        Copr repo for firefox-nightly owned by wanzenbug
fedora                                                                                                          Fedora 34 - x86_64
fedora-multimedia                                                                                               negativo17 - Multimedia
fedora-nvidia                                                                                                   negativo17 - Nvidia
google-chrome                                                                                                   google-chrome
updates                                                                                                         Fedora 34 - x86_64 - Updates
sudo dnf list all *nvidia* --showduplicates                                  
installed packages
nvidia-driver.x86_64                                                                                         3:465.19.01-1.fc34                                                                       @fedora-nvidia   
nvidia-libXNVCtrl.x86_64                                                                                     3:465.19.01-1.fc34                                                                       @fedora-nvidia   
nvidia-persistenced.x86_64                                                                                   3:465.19.01-1.fc34                                                                       @fedora-nvidia   
nvidia-settings.x86_64                                                                                       3:465.19.01-1.fc34                                                                       @fedora-nvidia   

available packages
akmod-nvidia.x86_64                                                                                          3:465.27-1.fc34                                                                          fedora-nvidia    
akmod-nvidia.x86_64                                                                                          3:465.31-1.fc34                                                                          fedora-multimedia
akmod-nvidia.x86_64                                                                                          3:465.31-1.fc34                                                                          fedora-nvidia    
dkms-nvidia.x86_64                                                                                           3:465.27-1.fc34                                                                          fedora-nvidia    
dkms-nvidia.x86_64                                                                                           3:465.31-1.fc34                                                                          fedora-multimedia
dkms-nvidia.x86_64                                                                                           3:465.31-1.fc34                                                                          fedora-nvidia    
kmod-nvidia.x86_64                                                                                           3:465.27-1.fc34                                                                          fedora-nvidia    
kmod-nvidia.x86_64                                                                                           3:465.31-1.fc34                                                                          fedora-multimedia
kmod-nvidia.x86_64                                                                                           3:465.31-1.fc34                                                                          fedora-nvidia    
nvidia-query-resource-opengl.x86_64                                                                          1.0.0-10.fc34                                                                            fedora           
nvidia-query-resource-opengl-lib.i686                                                                        1.0.0-10.fc34                                                                            fedora           
nvidia-query-resource-opengl-lib.x86_64                                                                      1.0.0-10.fc34                                                                            fedora           
nvidia-sdk-optix.noarch                                                                                      7.1.0-1.fc34                                                                             fedora-multimedia
nvidia-sdk-optix.noarch                                                                                      7.1.0-1.fc34                                                                             fedora-nvidia    
nvidia-sdk-optix-samples.noarch                                                                              7.1.0-1.fc34                                                                             fedora-multimedia
nvidia-sdk-optix-samples.noarch                                                                              7.1.0-1.fc34                                                                             fedora-nvidia    
nvidia-sdk-video-codec.noarch                                                                                1:10.0.26-2.fc34                                                                         fedora-multimedia
nvidia-sdk-video-codec.noarch                                                                                1:10.0.26-2.fc34                                                                         fedora-nvidia    
nvidia-sdk-video-codec-samples.noarch                                                                        1:10.0.26-2.fc34                                                                         fedora-multimedia
nvidia-sdk-video-codec-samples.noarch                                                                        1:10.0.26-2.fc34                                                                         fedora-nvidia    
nvidia-texture-tools.i686                                                                                    2.1.2-1.fc34                                                                             fedora           
nvidia-texture-tools.x86_64                                                                                  2.1.2-1.fc34                                                                             fedora           
nvidia-texture-tools-devel.i686                                                                              2.1.2-1.fc34                                                                             fedora           
nvidia-texture-tools-devel.x86_64                                                                            2.1.2-1.fc34                                                                             fedora           
pcp-pmda-nvidia-gpu.x86_64                                                                                   5.2.5-2.fc34                                                                             fedora           
pcp-pmda-nvidia-gpu.x86_64                                                                                   5.3.1-1.fc34                                                                             updates

Finally found the problem.

After the cleanup, the problem persisted, moved back again to rpmfusion and the problem, still there, but now, a bunch of things from rpmfusion missing… Tried to install akmod-nvidia and after a careful filtering:

  - package xorg-x11-drv-nvidia-3:465.31-1.fc34.x86_64 is filtered out by modular filtering                                                                                                                                                                                                                   

decided to give a look at dnf list modules:

Name                                                         Stream                                                 Profiles                                                                Summary                                                                                                           
nvidia-driver                                                latest-dkms [e]                                        default, fm, ks                                                         Nvidia driver for latest-dkms branch                                                                              

[e] indicates enabled.

sudo dnf module disable nvidia-driver and bingo. Problem solved.

How this module was enable? I don’t know… I never used modules, never gave a dnf enable module ... in my life… now I will restore to a ~ 5 days ago snapshot to revert all this app manager squeezing and apply this fix an clean up my repo list a bit.

1 Like

I find that every time I do an upgrade or new install the fedora modular repos are enabled. I hate the idea of the system taking actions during installs or updates that I don’t approve beforehand, so it is routine for me to disable the modular repos as soon as the install or uprade completes and before I do the first major update.

As such, with that practice, I have never had any issues whatsoever in out-of-sync packages. I know the use of flatpaks and modular repos is for the purpose of making it simpler for the newer user, but to me it seems to introduce complexity and sometimes conflicts in managing a system so I avoid both…

1 Like

I’ve searched a bit and it appear not to be connected to default modules but something to do with a fail safe procedure that happens in specific conditions of a repo not being available or something like it, happens. This module disappeared after disabled… I was surprised because I dist-upgrade since 26 and have disabled modules a long time ago, and apart from this case, fedora-modular and fedora-update-modular are still disabled.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.