Dnf mirror issues with ACT Please help


My friend has a fresh Fedora installation. He is doing his first sudo dnf update
The first time he did (on the wired connection) he got this error

Fedora was only finding this mirror and was not able to update as this was timed out and has no another mirrors to try I don’t know why. he tried sudo dnf clean all many times he got the same error with same mirror.

He then switched to wifi again did clean all and dnf update.

And he got zchunk checksum errors

These are also almost same mirrors from ACTcorp.
Also ACT is his internet provider. What can he do ! please help. Or just remove ACT mirrors from fedora please !

Please show us your dnf.conf:
cat /etc/dnf/dnf.conf

What DNS server are you using?
Check with resolvectl status

If it is from your provider try to change it to a dns like
After check again resolvectl status if your current DNS server is what you changed it for.

Now do sudo dnf clean and sudo dnf makecache to see if you get an other mirror.

1 Like

I didn’t thought about that wait he will change the DNS, i will report back here if it fixes it.


It Worked ! We used quad 9 but ya DNS solved this ! Thanks. Also can we delete this topic as it has IP address in the logs.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.