Dnf cores when updating from 30 to 31

, ,

I had just installed Fedora 30 a few mins ago. Logged onto the system and things seem to be running.
I decided to upgrade the Fedora 31 right away and did the usual upgrade package checks after installing 30. Then tried to upgrade to 31 by:
dnf system-upgrade download --refresh --releasever=31

dnf hangs and cores when processing Visual Code:

Adobe Systems Incorporated 13 kB/s | 2.9 kB 00:00
Fedora Modular 31 - x86_64 40 kB/s | 17 kB 00:00
Fedora Modular 31 - x86_64 - Updates 34 kB/s | 12 kB 00:00
Fedora 31 - x86_64 - Updates 34 kB/s | 13 kB 00:00
Fedora 31 - x86_64 47 kB/s | 17 kB 00:00
google-chrome 16 kB/s | 1.3 kB 00:00
RPM Fusion for Fedora 31 - Free - Updates 5.4 kB/s | 3.0 kB 00:00
RPM Fusion for Fedora 31 - Free 6.5 kB/s | 3.2 kB 00:00
RPM Fusion for Fedora 31 - Nonfree - Updates 5.9 kB/s | 2.9 kB 00:00
RPM Fusion for Fedora 31 - Nonfree 6.1 kB/s | 3.0 kB 00:00
Visual Studio Code 36 kB/s | 3.0 kB 00:00
terminate called after throwing an instance of ‘libdnf::ModulePackageContainer::EnableMultipleStreamsException’
what(): Cannot enable multiple streams for module ‘ripgrep’
Aborted (core dumped)

I tried removing Code and still got the same error.

Any idea what could be going on here?


Try this:
Disable the Visual Studio Code repository and run the upgrade again

What happened?

Might be:
https://bugzilla.redhat.com/show_bug.cgi?id=1811234 ?

you might try sudo dnf module reset ripgrep
then do the upgrade

Update: worked into the night and was able to upgrade from 30 to 31! Finally.
I am writing this on an old laptop running Fedora 31!!!
Thanks @twohot and @grumpey!

So a couple of observations

@grumpey: I just ended up removing ripgrep and that seemed to have done the trick.

@twohot: I didnt disable the repo, but just removed the package twice. Wish i had seen your response while I was tryging to fix the upgrade. I would tried ignoring the repo. After the second removal of Code and during the second upgrade attempt, when dnf hit Visual Studio, the cpu pegged for a second or two, but this time around dnf proceeded and didnt core.

1 Like

Awesome. I’m grad you’re back to enjoying Fedora. Don’t forget to mark the post as ‘solved’.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.