Disable GNOME-Software Update Notifications

tldr; My DE is Cinnamon on F36, is there a way to stop GNOME-Software from pinging me with updates?

When I first started using Fedora and Cinnamon, the ex-windows user and Linux noob in me caused the voice inside my head to make me use the nice GUI GNOME-Software Centre to search for and install software.

My Linux balls have since dropped and I now, pretty much exclusively, use the much preferred command line dnf yet I still retain a pretty gui 'dnfdagora-updater'for informing me of those important (and not so important) updates to packages etc.

I don’t really want to uninstall GNOME-Software as, whilst it isn’t all that good, it’s keyword search can give clues, as to what software packages might, I said might, because you never know, it might, suggest some appropriate packages. Although I now typically DuckDuckGo the suggestions anyway, before installing via dnf if they seem worthy (did someone say Google is my friend, because that’s another topic entirely, just kidding :wink: ).

So, how can I shut up GNOME and let dnf do the heavy lifting from now on?

You’ll want to dnf install dconf-editor if you don’t have it installed already. Once you do, you’re going to want to navigate to /org/gnome/software/allow-updates:

You should be able to enable/disable it from here. There are a few other options available at /org/gnome/software if this doesn’t quite get what you want (idle download notifications, etc.).


@vwbusguy you Sir, if I had a bacon sandwich, it would be all yours.

I should have known to look in dconf, but as you probably know, it is a minefield. But thank you, you have save me many hours of trawling.

Strangely, the change does not hide the [update] tab as described, but it no longer functions and that is good enough for me.


1 Like

just for future reference:

gsettings set org.gnome.software allow-updates false