Directory fails to mount with nfs4

I’ve taken the (spinny) disk out of my old (F35) workstation (because I’ve bought a new one) and put it in the local server and tried to mount four points, my old home directory and three of its subdirectories.

Three of them mount (on boot from fstab) as nfs4 but one (subdirectory) will only load as nfs.

Trying to mount it manually complains of insufficient permission.

I’ve set up idmapd, I’ve checked the permissions on the directory, I’ve aligned the user and group names and ids, I’ve tried switching off SELinux, no luck.

I had previously mounted all four points when the disk was in a removable socket linked to the server by a USB cable, and this worked, so it’s doesn’t seem to be a networking or even general machine issue…

What could it be? Or at least, where can I look?

I don’t know (a missing kerberos ticket?). But you might have better luck getting an answer on https://ask.fedoraproject.org/

Really? It didn’t seem so relevant, but I’ll do that, thanks.

< Later > while checking my message before posting it in Ask Fedora I’ve found my error, which was that I hadn’t set permissions correctly. :unamused: Fixed now

1 Like