Desktop manager no longer starts automatically


Not new to Linux but new to Fedora and prefer to spend minimal time administering and troubleshooting.

I ran Ubuntu for years but then switched and have been perturbed to run into issues so soon.

I am not at all sure what happened but suddenly the login manager doesn’t seem to want to hand off nicely to the desktop manager. I have XFCE and Gnome installed and face the same issue with both. The install is Fedora 36.

I’ve been staring at /var/log/messages until my eyes bleed. And in the meantime nothing under /etc/X11 makes sense any more lol.

Running startx from an ALT terminal works fine though dumps me in Gnome by default (bleurgh).

Where do I start troubleshooting? My google-fu really isn’t up to snuff these days.

Thank you for any tips!

Can you please share your system specs with inxi -SMCI. /var/log/messages hasn’t existed by default in Fedora in a while as it’s all in journald now. Use journalctl to see system logs.

This is a blast from the past. These days, the gdm service is what kicks things off for Gnome and Wayland is the default. You can pick XOrg when you log into Gnome, but on many systems, xorg is no longer needed, and the conf along with it.

Thanks a lot Scott for replying. Here is the output you are looking for:

  Host: Apollo Kernel: 5.18.19-200.fc36.x86_64 arch: x86_64 bits: 64
    Desktop: GNOME v: 42.4 Distro: Fedora release 36 (Thirty Six)
  Type: Desktop Mobo: ASRock model: B550 Phantom Gaming-ITX/ax
    serial: <superuser required> UEFI: American Megatrends LLC. v: P2.20
    date: 08/05/2021
  Info: 8-core model: AMD Ryzen 7 5700G with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 3988 min/max: 400/4919 cores: 1: 3990 2: 3993 3: 3991
    4: 3987 5: 3990 6: 3989 7: 3991 8: 3964 9: 3993 10: 3990 11: 3985 12: 3991
    13: 3988 14: 3991 15: 3992 16: 3987
  Processes: 521 Uptime: 4m Memory: 27.28 GiB used: 3.24 GiB (11.9%)
  Shell: Bash inxi: 3.3.19

Can you also post:
systemctl status display-manager.service
ls -l /etc/systemd/system/display-manager.service


1 Like

Hi Joe, thanks again for your reply.

Here’s the data:

● gdm.service - GNOME Display Manager
     Loaded: loaded (/usr/lib/systemd/system/gdm.service; enabled; vendor preset: enabled)
     Active: active (running) since Fri 2022-08-26 11:20:07 BST; 20min ago
   Main PID: 1210 (gdm)
      Tasks: 3 (limit: 33452)
     Memory: 4.4M
        CPU: 89ms
     CGroup: /system.slice/gdm.service
             └─ 1210 /usr/sbin/gdm

Aug 26 11:20:07 Apollo systemd[1]: Starting gdm.service - GNOME Display Manager...
Aug 26 11:20:07 Apollo systemd[1]: Started gdm.service - GNOME Display Manager.
Aug 26 11:20:22 Apollo gdm-password][3227]: gkr-pam: unable to locate daemon control file
Aug 26 11:20:22 Apollo gdm-password][3227]: gkr-pam: stashed password to try later in open session
Aug 26 11:20:23 Apollo gdm[1210]: Gdm: GdmDisplay: Session never registered, failing

lrwxrwxrwx. 1 root root 35 Jul 10 22:01 /etc/systemd/system/display-manager.service -> /usr/lib/systemd/system/gdm.service

Also saw the following in the journal which may be relevant (in red):

Aug 26 11:20:08 Apollo dbus-broker-launch[1249]: Ignoring duplicate name 'org.freedesktop.FileManager1' in service file '/usr/share//dbus-1/services/org.freedesktop.FileManager1.service'

Aug 26 11:20:08 Apollo gnome-session-binary[1254]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed
Aug 26 11:20:08 Apollo gnome-session-binary[1254]: GLib-GIO-CRITICAL: g_bus_get_sync: assertion 'error == NULL || *error == NULL' failed

For now I have switched greeters from gdm to sddm (worse than before, my entire graphical output vanished for two minutes then was returned to the greeter) then switched from Gnome Classic to XFCE and now everything is working.

Something broke my Gnome :frowning: