Desktop Entry not running at startup

Hello everyone, I’ve three Desktop Entries in ~/.config/autostart/.
I’ve created one of them to convert my keyboard map at startup, because of a issue explained here.
One day It stopped working and I don’t know why, I haven’t changed the file.

[Desktop Entry]
Exec=setxkbmap it

I’ve given it execution permission too.
How can I solve or debug this issue?

I’ve tried to edit the lines as follow but no terminal appears at startup:



Does manually running:

setxkbmap it

Still work?

Thanks Tom.

Yes, manually the command works perfectly.


I’m away from my fedora machine, I’m just spinning up a vm, to see if I can reproduce.

Thanks Tom.


Your autostart desktop entry works fine as long Gnome is running in an Xorg session:

If I login using a standard Gnome (Wayland) it doesn’t work, not even if I run the command manually. So your command only works for xorg/x11 not wayland. The fact the command runs manually for you would suggest you logging on with “Gnome on Xorg”, is that the case?

Thanks Tom.

I was running in a Wayland session.
Now I’ve tried both Wayland/Xorg, with and without Desktop Entry, checking for keymap issue.

Wayland with Desktop Entry: works
Wayland without Desktop Entry: doesn’t work
Xorg with Desktop Entry: works
Xorg without Desktop Entry: works

So Xorg doesn’t need the setxkbmap it command, and relative Desktop Entry.
Wayland has problems, so it needs the Desktop Entry, that was not working previously, but now It’s working.

I’ve also solved a system update issue during this time, following this and updating the system, so I think this update has solved the problem with Wayland and the Desktop Entry.

1 Like