Desktop and nvidia issues after latest updates

After getting the latest Fedora updates, I’ve been experiencing some issues with my desktop. The attached image shows that my apps are flickering, which wasn’t the case before the update. Additionally, I’m unable to use Brave and Chrome browsers as its not rendering see the images below. I had no problems with Nvidia or anything else before the update.


Also, I can see the notification error as followes:

A kernel problem occurred, but your kernel has been tainted (flags:POE). Explanation:
P - Proprietary module has been loaded.
O - Out-of-tree module has been loaded.
E - Unsigned module has been loaded.
Kernel maintainers are unable to diagnose tainted reports. Tainted modules: vboxnetadp,vboxnetflt,vboxdrv,nvidia_drm,nvidia_modeset,nvidia_uvm,nvidia.

So this is the output of dnf list installed 'nvidia':

akmod-nvidia.x86_64                                     3:550.67-1.fc39                 @rpmfusion-nonfree-nvidia-driver
kmod-nvidia-6.7.9-200.fc39.x86_64.x86_64                3:550.67-1.fc39                 @@commandline                   
kmod-nvidia-6.8.5-201.fc39.x86_64.x86_64                3:550.67-1.fc39                 @@commandline                   
kmod-nvidia-6.8.6-200.fc39.x86_64.x86_64                3:550.67-1.fc39                 @@commandline                   
nvidia-gpu-firmware.noarch                              20240410-1.fc39                 @updates                        
nvidia-modprobe.x86_64                                  3:550.67-1.fc39                 @rpmfusion-nonfree-nvidia-driver
nvidia-settings.x86_64                                  3:550.67-1.fc39                 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia.x86_64                              3:550.67-1.fc39                 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-cuda-libs.x86_64                    3:550.67-1.fc39                 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-kmodsrc.x86_64                      3:550.67-1.fc39                 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-libs.x86_64                         3:550.67-1.fc39                 @rpmfusion-nonfree-nvidia-driver
xorg-x11-drv-nvidia-power.x86_64                        3:550.67-1.fc39                 @rpmfusion-nonfree-nvidia-driver

This is the output of sudo dmesg | grep -i taint:

[    6.199150] nvidia: loading out-of-tree module taints kernel.
[    6.199155] nvidia: module license 'NVIDIA' taints kernel.
[    6.199156] Disabling lock debugging due to kernel taint
[    6.199157] nvidia: module verification failed: signature and/or required key missing - tainting kernel
[    6.199158] nvidia: module license taints kernel.
[    6.422986] nvidia_uvm: module uses symbols nvUvmInterfaceDisableAccessCntr from proprietary module nvidia, inheriting taint.

FYI, I have Asus ROG Strix G16 with nVidia GeForce RTX 4050 6GB

This may be relevant.

Thanks @computersavvy, but I don’t think that’s pertinent. I’ve already checked the installed packages sudo dnf list installed | grep nvidia, and compared the loaded kernel modules with Nvidia modules lsmod | grep nvidia. The modules are loaded, so It seems that Nvidia is functioning.

Hey Jeff @computersavvy, any ideas about the cause of such issues?

The graphical issues I posted occur only when Chrome or Brave is active. It seems that the latest update for Chrome and Brave, which includes --ozone-platform=wayland, has caused these issues.

1 Like