Dell XPS 13 2020 Fedora 33 hangs on boot after kernel update video issue

Greetings all

I have a Dell XPS 13 from 2020. The latest kernel update, to 5.9, caused the machine to hang on boot. A rainbow pattern in a grid appears on the screen where I would expect to enter my disk encryption password. (See attached image).

Any advice is much appreciated!

Everything works fine in the old kernel, which I am using for now.

This kernel is still in updates-testing — thanks for trying it out. Please report the problem in the update here: (including the GPU – as I understand it that’s not always the same in all XPS 13 models). Thanks!

Got it—thank you—I’ll put in a report.
I have since removed it and unsubscribed from the updates repositories. I had subscribed to them when there was a problem with my audio, which was solved with a 5.8 update.
Thank you!

1 Like

Now this has been released outside of the testing stream and this bug is still there. I am still seeing the same video behavior on startup. Is there anything more I can do besides set the old kernel to default and wait for a fix? I don’t know where to begin troubleshooting!

Thank you!

This was solved. See my follow-up post at

Thanks to all who contributed.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.