Dell: Battery drained while suspended

I installed Fedora 34 to a new Dell XPS 13 9300. Updated the BIOS, installed TLP, tested your recommendations from this thread like sleeping without using the lid, etc.

But the battery keeps draining while in s2idle. I’ve calculated it to a rate of 5% per hour drain while sleeping. I have some days left while I can still return the computer and I’ll try to make it work but so far there is no indication that anybody has solved the battery drain that some of these Dell laptops experience. If anyone has a suggestion, I’m happy to hear it.

1 Like

(Split it to a new thread because the old one was now a year old)

Is the system correctly suspending? Can you check the journal logs to see if there are any errors etc. near suspend?

If it’s a software issue, that should hopefully tell us.

I have the same problem with XPS 15 (9500) the system suspends just fine. 9500 does not support s3 suspend so what we are left with is s0ix but the battery drain is a killer :frowning:

1 Like

Ah, so this is a hardware issue then? (I haven’t had a dell in years now!)

Found this which apparently has some steps (but still does not work from the looks of it):


Right, the dell forum search for “Linux battery drain” contains multiple entries, all of them unresolved as to why the laptops keep draining battery during sleep (either through lid closed or through the system menu or through command line). The impact is pretty bad for the user, I tested multiple times (with Debian as well) and calculated a rate at 5% loss per hour, your laptop basically dies in less than 24 hrs.

I don’t know how Dell allows this, their Linux customers are reporting that in the forum and they just ignore them. On top of that, getting the laptop back to windows stops draining the battery in sleep. Which means only one thing, Dell hasn’t tested and fixed sleep in some of their laptops under Linux.

And Dell seems to understand it, in one post I read they refer to this as “modern standby” (triggered by s2idle) and they ack it will continue to consume resources, in order to go to proper sleep, the device must enter “deep” instead of s2idle. Well, that would work except that such option is not available.

sudo cat /sys/power/mem_sleep

Only s2idle (the battery greedy one) exists. I followed instructions on how to enable it from the boot loader options and later I learned it’s removed at the firmware level (warning, long thread).

Equally frustrating and as a side note, they use a fingerprint vendor which also has tens of requests to support Linux, but Goodix deflects or ignores such requests in every case.

I understand Dell sells computers with Linux but that only helps them if they extend their platform testing and compatibility to the rest of their models. I will return this computer, it’s a nice piece of HW and I wanted to make it work but my advice is that Linux users should stay away from Dell computers.


That’s really unfortunate. Did you try the one workaround that seemed to work for some folks—changing from RAID to AHCI in BIOS?

1 Like

good suggestion, I’m doing a BIOS reset and a clean install to test this RAID disabling in the BIOS. I’ll report back later in the day with results.

I had tested a bunch of things in the BIOS so I may have tested this along with other BIOS setting changes. Hence I think it’s better to do this as clean as possible.


The clean install sounds good to me.
Note that some distro installers are totally unable to see the drive in certain Dell machines when it is set to RAID. Switching it to AHCI usually fixes that issue.

1 Like

I’m pretty sure my 9500 is set to AHCI and the drain is there so don’t hold your breath. I have couple of kernel bugzillas opened. The first confirmed that S3 is not supported on 9500 although it is present as an option. The second… seem stuck - noone is working on it.


to my surprise, the RAID to AHCI change in the BIOS (and that change alone) actually fixed the battery drain. I measured over 20 hours of sleep, occasionally waking it up to check the battery percentage, and it drained only 7% during 20.5 hrs. Out of the box and installing Fedora 34, it used to drain 5% every hour. To compare apples to apples, it’s an hourly sleep consumption rate of 5% (RAID) vs. 0.3% (AHCI).

I will keep the XPS and wrestle the next issue I’m facing which is extended desktop errors. I’ll document that separately.


Ah, that’s good. Glad that worked out. These issues are tricky—some workarounds work on particular hardware, and not on others etc :confused:

Hi, I see this was solved (temporary?) by switching to AHCI for fedora. I was wondering if there is any progress on the RAID side on fedora? My XPS 9310, configured with RAID, is having great battery life with Ubuntu (tried 20.04 to 22.04) on par with Windows if not better. I tried every release of fedora since 34 up to the recent version 36, hoping this would be fixed somehow. I can confirm the battery still drains as described above in version 36. So I was wondering if anybody has an idea at what exactly Ubuntu is doing to enable their stellar battery life on RAID, and if this could be somehow ported to fedora? I really like fedora, but I am dual booting with Windows which is configured on RAID and I don’t want to change that to AHCI. Thanks

Thanks for pointing out that worked for you. I am wondering if the switch from RAID to AHCI on BIOS led to any loss of data. Did you have to backup your data and then reinstall Fedora and all that?