Dell 5420 - Weird screen error/glitch - Is this hardware or software?

Hi all, thanks to many great users on here I have finally got myself a gorgeous new machine. It’s used, but looks mint, not a mark on it and from a good seller (with warranty I think, not certain though).

Spent many hours getting F40WS set up, i love this machine and thanks to advice of users on here it seems almost completely perfect in terms of Fedora and hardware compatibility. Everything seems to work (except losing power during standby, oh not that old chestnut again!) Anyway, that’s not what this thread is for…

I have used it for a day or two, quite intensively setting up files, emails, apps etc. Then today I connected ethernet, checked emails, unplugged cable then picked up laptop and moved about 10 feet, put it down on coffee table (gently). It instantly showed a screen error, no point describing as I took pics and a video…

Here’s a video to show the actual live behaviour…

Damn, can’t upload, here’s a link to download the clip - Lufi - Disroot file uploader

PS A related question which seems a good time to be asking - is there a way to test all computer hardware with some kind of app available for Fedora?

I used Macs in the past and used Apple Hardware Test and MetTest86 for RAM tests. No idea how to test my hardware in LInux.
thanks

Is this device coming with an NVidia GPU? It looks hardware related, possibly a connection internally if you just moved it from one location to another. It could be driver related, but it seems unlikely if it has been fine up to now. I had a Compaq (owned by HP) that would get weird with the position of the lid.

1 Like

Thanks for replying.
What I am concerned about is whether to return this laptop while I still can. I REALLY don’t want to though! I’ve spent hours setting up and getting used to it and i am really happy with it. You could be right abuot the screenhinge, i tried wiggling, jolting and moving laptop around, including repeating the exact steps that happened beforehand, didn’t do it again.
I wasn’t sure about GPU but found hardware listed in settings, if this helps?

image

Thanks again, may have to just hold my breath and hang on. Would be good if there was some kind of hardware test utility i could run in case it picks up any hardware faults. It’s been perfect other than this

I would pop the bottom cover off (usually just a few screws) and look for damaged cables or connectors not fully connected, RAM modules not properly seated, etc. Many resellers take a couple damaged systems and cobble together one “working” system. It is all too easy to leave something connector not fully secured while mixing and matching components. Some types of damage (water) can case progressive failure due to creeping corrosion.

Many Dell systems have a memory test that can be run from the “BIOS”. Does the problem occur using a Live Linux USB key?

1 Like

Did you contact the seller with your issue? That would be my first inclination if I was in your shoes. Usually it will get you the most mileage just to ask them what they think could be the issue.

P.S.: If you get no satisfaction from your question, that would persuade me to send it back for refund or different option. I don’t mind Dell, but have better luck with Thinkpads running Linux without issues.

1 Like

Thanks, some great advice there. I will inspect inside.
It didn’t happen with live USB, but it’s only happened once and I didn’t use live usb for longer than necessary to install Fedora. I don’t expect it will happen often so not easy to find out if would happen with live USB. I’ll have a look inside, and I think I have memtest86 on a USB somewhere which I suspect would be a more thorough test of RAM.
This machine has 32GB so it’s conceivable that it has been opened up to add more at some point (not sure they ever sold with that much from factory)
thanks again

Good idea thanks. Can at least suss him out a bit, i am careful who I buy from, turn down 95% of sellers, so I expect a good response, but wise to test the water and see what he thinks.

I can’t get on with thinkpads at all. I did prefer Lenovo generally, never been a fan of Dell, but my Yoga 16ARP8 was a long string of troubles (bad audio, no mic, various others) and I was forced to downgrade to raise funds. This Dell really has impressed me way beyond my expectations, from the keyboard to the cam shutter (better than lenovo one which requires fingernails!), and the audio is damn good for such a cute little thing 14". I don’t like Dell XPS, hate that rubber surface, but this reminds me of a macbook air in feel to use, but nicer. Very happy with it, so I am a fan of the 5420 if not any others! It was also a bargain and is in beautiful condition, not a blemish.

Anyway, I better get on with opening it up to check for nasties!
thanks all

PS just checked and I have 3 months warranty, contacting seller now in case he has any ideas

I was attracted to them but found they were not up to the tasks I had in mind. I found the Thinkpad’s and the Thinkpad Edge to provide very good performance, again for my use. My X250 is an absolute workhorse for me.

I like their screens, they always had some of the best options for screens on laptops, and again this is from my perspective of using laptops in less than perfect places, like beside a manufacturing line in an industrial environment, or hanging off the side of a crusher or rock saw. Anyway, I have an Inspiron that still has a nice sharp and clear image on it’s screen, and it’s from 2003 ish

I absolutely love the thinkpads, i only they would do one without the rubber keyboard trackpoint thing, I just can’t get on with any keyboard with those (and yes i tried removing it, which just left sharp edged keys). I type very fast and any interruption to my workflow causes major issues, 4 mouse buttons isn’t ideal for me either. Other than that I would have a thinkpad and never consider any others. That’s actually why I went for the Yoga (gamble), hoped it would be a thinkpad without those issues, but it isnt. Nice machine, but I much prefer this Dell (and the Yoga had major problems running Fedora, just not worth hassle, I am sure it will get better support in time but I can’t wait right now, need to get 5hit done :slight_smile: )

I would look for the ends of the video connector, the connectors on the flat cables are quite small and sensitive to incorrect insertion. They are usually pretty hardy when reseated correctly. The clam shell lids are always an area of concern.

1 Like

I never even notice it unless I choose to use it. I know some people seem to have major brain infarctions over it, I just don’t get it though. One of the benefits of programming for various equipment manufacturers and turn-key solution providers, was the abundance of variety in laptop brands being used by them. All that cross exposure is a benefit I guess.

Yes it is.
As someone who has sat a desk with the same keyboard (Apple A1423) for 20 years or so, 14 hours a day, 90% of which is typing documents, I don’t have that agility! I dont know of anyone else with the issue, all I know is it’s a horrible experience for me personally, and that makes it a no go. (I have tried more than a few times, including Dell Latitude with similar trackpoint). Muscle memory and all that (and age!)

Instant reply from seller:

" Hi, sorry to hear about the issue. Did you install any software on the laptop? I would advise to run dell diagnostics to find out if there’s something wrong with the hardware(when you turn on the laptop and see dell logo please press F12 and select diagnostics) please let us know what’s the outcome.

Best regards,
Matt"

Hopefully I can run this utility as it sounds like it’s in BIOS

I believe it is.

Dell diagnostics are in bios, but needs Dell own windows and partitions and recovery parts so on Linux your out of luck running those at least on my Dell XPS it is that way

Thanks but didn’t understand that fully. I just ran a full test in diagnostics from BIOS and it all ran properly.
No errors found in any of the hardware.
Next step is to open and visually inspect, but I see the seller has put a security sticker over one of the screw holes (to prevent theft of parts I assume, happened to me when I sold a machine once). I have asked him if it’s ok to remove that and then I will take a look.

Can I just ask - looking again at the image/video of the error, is there ANY CHANCE that can be a software/OS issue? Or do you guys think that’s not possible?

At this point there is no need to visually inspect inside the system. If the display works properly for diagnostics I would run memtest86+ for extended periods (overnight, multiple days). Do you have another system that can connect to the laptop via ssh. This could allow you to make sure the kernel is still running when the display goes bad. Have you checked for evidence of problems using journalctl? With issues like this it is helpful to keep a log of the timestamps when the problem occurs. Journalctl collects massive amounts of information, so it can take some work to create a filter that isolates the relevant details, but if you are restarting the system then you can look at the end of the previous boot (journalctl --no-hostname -b -1 | tail -N where you can chose N so the output starts just before the problem occurred.

Above my abilities that but thanks. I can run MemTest86 though.
I was hoping someone might have seen something like the error screen I got before, or at least has enough experience (if it’s even possible) to take a guess such as ‘definitely video card related’ or whatever. A long shot I know!
I will test RAM more thoroughly, may as well since I have the utiliity on a stick
thanks

People who get a similar garbled screen can’t yet easily search for similar images, so you are much more likely to reach the right audience with a text error message from journalctl.

Make sure you are using the current Memtest86+ v7.00 Released: 2024-01-07. It is included in the Fedora Workstation Live Installer.

You should also make sure you have the current Dell firmware updates. You should be able to use sudo fwupdtool get-updates to see a list of available updates.