Default DNS configuration: Many web pages are not opening on fedora 39


The default DNS configuration in fedora 39 may cause many web pages to load very slowly. Specially in wifi network.

Solution: Go to settings->network/wifi->change DNS to desired value and it will work.

Certain websites are not opening in fedora - #4 by vgaetera

This report does not include enough information to have even idea, what might be the problem. On common networks, network provided DNS should work well. please share at least output of resolvectl command. What exactly happens on a name, which will not open? Can you use dig from terminal and share, what it responds?

If local DNS does not work well, it should be reported to operator (administrator) of the network. It might be filtered intentionally or configured wrong way.

Its a simple observation and a simple solution to resolve the issue. No point making it complicated.

Setting a dns server address manually IS making it complicated for most users. The default config with a dhcp provided dns server works for the great majority of users.

If you were to follow the suggestions and provide the requested info we may be able to find out why the default is not working for you while it does work for almost all users.

setting a dns server depends on need of the user. if anyone thinks it is complicated for him/her then he/she may learn the same. Any statics available for default config with a dhcp dns servers status? If yes the source should be mentioned.

If you follow the post closely I never wanted your suggestion rather I mention a workaround if page loading is slow. Here your precious analysis is not required.