Custom screen resolution problem

Hi everyone,

I have just replaced the screen in my laptop because the last one cracked after years of loyal service. At first boot everything worked, except it is not possible to choose a resolution higher than 1366x768. To fix this problem I found this thread which offered solutions:

The answer in that topic shows how to add custom resolutions with xrandr. However, I can manage the first few steps provided, but in the last one I get an error that I haven’t been able to find any information on.

In this last step I type:
xrandr --output XWAYLAND0 --mode "1920x1080_60.00"

the output I get is:

Blockquote X Error of failed request: BadValue (integer parameter out of range for operation)
Major opcode of failed request: 139 (RANDR)
Minor opcode of failed request: 21 (RRSetCrtcConfig)
Value in failed request: 0x0
Serial number of failed request: 22
Current serial number in output stream: 22

After typing: xrandr I get:

Blockquote Screen 0: minimum 16 x 16, current 1366 x 768, maximum 32767 x 32767
XWAYLAND0 connected 1366x768+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
1366x768 59.80*+
1024x768 59.92
800x600 59.86
640x480 59.38
320x240 59.52
720x480 59.71
640x400 59.20
320x200 58.96
1280x720 59.86
1024x576 59.90
864x486 59.92
720x400 59.55
640x350 59.77
1920x1080_60.00 59.96

So it seems xrandr --newmode and xrandr --addmode have done their job, but some other step is required before xrandr --output will work.

Is there anyone who can help me out to fix this?

Thanks in advance.

Hi @asmita and welcome to ask fedora! when you have time maybe you want check out the section #start-here

I will comment you some points what can help you with it:

  • A) It looks like you are running fedora in wayland session because the output of xrandr is xwayland, and xrandr is not woriking under wayland let’s say it only does work in “ro” mode (read-only). So you will can not change anything in wayland session with this command and in xorg will work only temporary mode to test the configurations.

  • B) How xrandr did show you , your monitor can’t not support a bigger resolution than 1366x768(16:9) and 1280x720 (4:3) at 60 Hz of frequency. Not at least with your actual driver what can be nouveau (if you have a nvidia card) or amdgpu (if you do have a amd card) or the i915 if you do have a intel CPU+GPU (hybrid) I assume that there is not a driver nvidia because like said before you are running Wayland session what is not compatible with the nvidia driver in the actual state. And the higher resolutions supported would work at a lower value of frecuency maybe 45Hz 30Hz 15Hz ( I don’t know) but in your actual state you are not disponible to use a higer resolution to 60 Hz.

To know a bit more about your Graphic stack you can run the commad below (this will show you the model of gpu and the driver in use by the kernel)

lspci -nnk | egrep -i 'vga|3d' -A 3

like it:

[jorge@f31 ~]$ lspci -nnk | egrep -i 'vga|3d' -A 3
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] [1002:67df] (rev cf)
	Subsystem: PC Partner Limited / Sapphire Technology Radeon RX 470/480 [174b:e347]
	Kernel driver in use: amdgpu
	Kernel modules: amdgpu
  • C) If you do have a nvidia gpu under nouveau and this one model of GPU is better that you integreted GPU (in case that you have one) maybe you should try install the privative driver trough rpmfusion in case your model is supported. And check with the privative driver of nvidia if you can reach a higher resolution and work under xorg session.

  • D) If you do have a hybrid CPU where his GPU is better that the nvidia or amd one (in case you do have one of them) you can see if the driver in use is the i915 if not you could enable it temporary in the boot process to check if the resoution that it does support is higher or no.

  • E) There one can change or force one determinated resolution in wayland but is to experts and dangerous under one parameter in drm module, but it is something what an normal user like you and me should never use to avoid damage the monitor.

  • F) if you actually are running the better option to run the graphic stack, you will be stacked in those resolutions at leats at 60 hz. (And you don’t would rearch run a higher resolution with less frecuency)

I hope this has helped you to understand your problem a little more. Maybe some more experienced user in the forum come with better/other tips.


1 Like

hi @xtym,

Thank you for your very comprehensive reply. This has led me to again follow the instructions on said previous topic in the link I supplied, but this time booting KDE, as it doensn’t use Wayland: it worked! However, the result is a small loss of quality.

Does anyone know if this loss of quality somehow possible to avoid?

External monitor?


Just leave you know that gnome also can be run in xorg session, you only need select this in the moment of your login, though of the “gear” where you can choose between gnome|gnome Xorg¡gnome classic. So if you like more gnome you can run it in xorg too.

Maybe it is related with the compositor KWIN under kde you can try change the options in the rendering turning off Vsync (never) and playing a bit with the options of scale to see if it does show a better quality.

Skärmbild från 2020-01-05 12-28-05

If you have still the gnome desktop try run the session in xorg and check if the quality is the same with kde so that you can isolate the problem and know if it is problem with the xorg server or with the compositor of the desktop.


1 Like

Thanks @vits95 and @xtym for your replies.

@xtym, I am content with using KDE. I have done some tweaks in font sizes and windows and for now I’m accepting that this is just the way it is going to be. The loss of quality does not get better (or much worse) through experiments with compositor settings, so I guess I’ll just stick to this minor resolution for now.

$ ./f_saucer -Os --pedantic-moron
"The quality doesn't get restored (or degraded further) through..."

🛸️ The Proper way to say is:

“We’ve a negative growth in quality, though upkeeping the stable and reliable stability!”

1 Like

Haha, I only partly agree with you on that, but we would need a different forum for such a language discussion… :nerd_face:

besides that, fixing the language problem doesn’t solve the display problem! :wink:

New forum (mai drim kamz try):

"Teh Langyadg kraimz"

“Rat: ******”
“Passyod: ******”

Yellkam, oya litl frend!
Toy shШall kip anonimoys xerepleis, for a seik of survaivel IRL!”

Topik: Elloy to eni intillidgent bein!
Link to tipo: ****. Diskyz…”

Koment: But it b’utifyl !!!
+[1] -[14]”

Koment: Xy nid to goy ayt ty ze stritz, yen yi kan jast maik fan of piplz maikin SYCHЧ taipos, lol Xa-Xa!
+[14] -[1]”