Custom Fedora 30 iso states that it is Pre-release/Testing version when using it to install to a HD

I have been using Lorax Livemedia-creator to create custom Fedora isos based on Xfce4. I recently created a custom fedora 30, but when I try to use it to install to a HD, Anaconda informs me that it is a Pre-release testing version and that it would result in an unstable system.

I commented out %include fedora-repo-rawhide.ks and uncommented %include fedora-repo-not-rawhide.ks in the fedora-repo.ks file and then flattened the fedora-live-xfce.ks, so the iso should not be a Testing version of fedora.

I have run into this problem since Fedora 28.

I would like any input from a user who has had experience rolling isos using Livemedia-creator.

Off the top of my head I would say that Anaconda is sort of correct since you are rolling your own spin that isn’t officially tested and therefore could result in an unstable system. So I think it is more of a cautionary note for someone you pass the iso on to, and pertains to the iso you created since that wasn’t “officially” tested. Just my thoughts on it, not that I make ISO’s from livemedia. If I get a chance later today I’ll try it for myself to see what your dealing with.

1 Like

@jakfrost thanks for your reply. The problem is that the iso is Testing, not stable; Anaconda Bluesky (testing) is installed in the iso and so testing anaconda will also be installed onto HD. On fedora 28 I had the same problem with lorax livemedia-creator. I went and installed it to 3 computers. I ended up removing the rawhide repos, but 2 of the 3 systems were problematic, so I ended up reinstalling fedora from scratch.

When installing from these custom isos, the process is quite fast, about 10 minutes. So when they work, they are fantastic.

Just to be clear I set up lorax so a stable iso would be created; before flattening the fedora-live-xfce.ks I modified the fedora-repo.ks, commenting out the rawhide repo and uncommenting the non-rawhide repo.

1 Like

Well, Brian Lane who is in charge of Lorax livemedia-creator solved this problem. He noted that generic-release in the %packages section of the kickstart has not been updated and therefore causes the build to be testing.

I will change the “generic-release” package to “fedora-release” and that (hopefully) will allow lorax to build a stable fedora30-xfce iso. After I run it, I will let everyone know whether that fixed the problem.

Since my custom iso will no longer be generic I will not be allowed to distribute it to anyone (which I rarely do)


Commenting out “generic-release” and adding “fedora-release” did the trick!

1 Like