Cursor uses basic X cursor occasionally instead of Breeze cursor


I recently upgraded to Fedora 34 KDE via a fresh install. I’ve had a few issues with it, one of which is that my cursor will occasionally use an X cursor instead of the correct one:


This happens no matter which cursor theme I choose. The one in the screenshot happens when I left click on any of the toolbar icons in Firefox. Does this indicate a bug or is it as simple as reinstalling a package? I’ve already tried reinstalling the Adwaita and Breeze cursor packages. I also upgraded to Fedora 35 thinking that might solve this problem and a few others I’ve been having, but this one didn’t get fixed.

Try to set the cursor in System Settings->Application Appearance->GNOME Application Style (GTK) too.
Or try to delete the file ~/.config/gtk-3.0/settings.ini (or at least remove the line “gtk-cursor-theme-name=xxx”).

1 Like

Should there be a cursor-specific option? All I’m seeing is a “GTK theme” dropdown with Breeze, Default, and Emacs as options. There wasn’t anything selected initially, but I’ve tried each of them and the cursor issue still persists. I also deleted the gtk-cursor-theme-name line in the gtk-3.0 settings.ini file, no change. I tried it in the gtk-4.0 settings.ini too and nothing changed.

  1. Are you on or wayland?

  2. Is it only that X that looks different?

I was on X. It looks like this particular issue is gone on Wayland, although it’s still present on the lock screen.

I did some testing on Wayland and it looks like more generally this is a problem with the cursor being animated. If I open LibreOffice in X, there’s a little bouncing LibreOffice icon to the lower right of the cursor, but in Wayland the cursor just disappears until the program finishes launching, at which point the regular cursor reappears. I think when the default X cursor in the screenshot above appears, that’s supposed to be the circular loading cursor. In Wayland, when the circular loading cursor should be displayed, the cursor just stays static and the loading cursor never appears.

Maybe this will help

After spending a while testing this, it looks like this has fixed the problem both in X and Wayland. Thanks!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.