Current issues in Fedora 31 alpha (with Silverblue)

I tried rebasing to Fedora 31 with Silverblue and hit the following issues:

  1. wireless networking doesn’t work: wpa_supplicant is not installed, iwd is used instead
  2. toolbox (or podman?) is broken
    • error: Error: unable to start container "test": error reading container (probably exited) json message: EOF
    • different error messages for an existing F30-built container or a new container
    • bug filed @ https://github.com/debarshiray/toolbox/issues/246
    • no known fix
  3. Firefox is older than the version in F30 (this prevents you from using your Firefox profile, as it checks and does not want to be downgraded)
    • This will be fixed whenever the most recent version of Firefox lands in F31; meanwhile, it requires creating a new profile or using another browser (which may include Firefox in a Flatpak or installing Epiphany or Chromium as a layered RPM)

I’m not sure if I would’ve hit two of these issues if I had upgraded to F31 on a traditional install. DNF would’ve probably kept wpa_supplicant and Firefox probably wouldn’t have been downgraded.

Thankfully, with Silverblue, it’s possible to rollback (except I changed too many things when installing/rebooting F31, so I cannot here on this machine) or rebase back to F30 (and reinstall the layered packages).

1 Like

I know today Firefox 69 was released today Sept. 3rd. So will that version be included in F31?

Firefox 69 should be shipping to F29, F30 and F31 it’s just that the package is failing to build.

https://koji.fedoraproject.org/koji/packageinfo?packageID=37

It is strange because according to the repo date both F30 and F31 should have exactly the same version of Firefox - 68.0.2.
And you don’t have to wait for another update of Firefox, just run firefox --allow-downgrade for the first time. it will not block your current profile and it worked just fine for me.

1 Like

The logs show that the version of cbindgen is too old, as the version of Rust required for Firefox 69 must’ve been bumped up.

From https://kojipkgs.fedoraproject.org//work/tasks/2758/37332758/build.log:

 0:09.25 ERROR: cbindgen version 0.8.7 is too old. At least version 0.9.0 is required.
 0:09.25 Please update using 'cargo install cbindgen --force' or running
 0:09.25 './mach bootstrap', after removing the existing executable located at
 0:09.25 /builddir/build/BUILD/firefox-69.0/.cargo/bin/cbindgen.

So it makes sense why F32 (rawhide) builds fine, but F29, F30, and F31 fail — the version of Rust in everything but rawhide is just too old.

1 Like

Issues 1 and 3 are solved now. 31.20190914.n.0 with no layered packages has Firefox 69 and wpa_supplicant.

I also saw that fedora now has a flatpak version of firefox. So perhaps we can remove firefox from the base image? It seems to be working fine as well.

Do you also have such RAM problem since rebasing to FSB 31? I have 16 GB on my machine, and everything was fine throughout the last years. But since 31, I easily get my RAM to almost full utilization and swap used. Then the system starts hangig often for half a second up to a minute.

Have you tried monitoring the RAM in the System Monitor to look for particularly hungry processes?

Yes, particularly Firefox is pretty excessive. On FSB30 I was able to run it with 6 windows and about 500 open (but not loaded) tabs in total (needed about 10 seconds to load and maybe 3…6 GB of RAM). On FSB31, starting Firefox with all my tabs blocks my system for several minutes and then is lagging really bad. But also other programs make excessive use of RAM. Chromium for example uses ~800 MB (I just start WhatsChrome, not Chromium itself).

So I now just use Firefox in private mode, and even then my System starts lagging after some time, when everything I have open is Spotify, one Epiphany WebApp, Geary, Firefox with <10 tabs, gedit and Nautilus. This load was not even the slightest problem on FSB30, something seems to be wrong here. :confused:

// Edit:
So with the latest version of FSB from today or yesterday, this has bettered a lot, still not completely resolved, but I guess people are working on it, as the first FSB31b images were even worse. The thing I currently noticed while having an htop window open, is, that going into the overview via pressing Super, allocates enormous amounts of RAM in the range of some gigabytes (more Swap than RAM actually). This then leads to screen (and sometimes even audio) freezes in the range of 10…20 seconds. Selecting other windows via Alt + “the key above tab” sometimes has a similar effect.

// Edit 2:
And the media keys often don’t work and make a restart necessary…

I’ve been getting a error calling StartServiceByName for org.freedesktop.fwupd: Timeout reached message when checking for updates in Software. Updating by command line seems to work, but I get an error notification that important updates failed to install after reboot (I think the notification is wrong).