Create a bootable microsd card for AllWinner cpu

I have a Orange Pi PC PLUS and I’m trying to install Fedora but I have some problems.
Generally I tested other distros (armbian etc) with no success and I don’t know what is wrong.

On Fedora’s case, I downloaded the xfce version from .
I tried both dd the .xz file and dd the extracted .raw file with no success.
Then I tried the program arm-image-installer with command

sudo arm-image-installer --image=Downloads/distro/Fedora-Xfce-armhfp-33-1.2-sda.raw.xz --media=/dev/sdb --target=orangepi_pc_plus --norootpass'

but I get some error messages like:

mount: /tmp/root: wrong fs type, bad option, bad superblock on /dev/sdb3, missing codepage or helper program, or other error. 
No U-Boot files found for orangepi_pc_plus. 

On fdisk I see that the sdb3 is a Linux partition, but I cannot mount it because it has bad superblock.

What might go wrong?

Sorry, I have the classic questions. :slight_smile:
Have you verified the downloaded image? (Maybe an incomplete/corrupted download?)
Did you try with another SD card?

1 Like

I got the solution from Fedora’s arm list. I had to add ‘–resizefs’ and the problem I had with the wrong filesystem was from defective microSD.
Problem solved.

Please @alextheoto, mark the topic as solved :+1:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.