Crash after first login

So I reinstalled fedora using the everything iso. After booting into kde everything appeared fine at first. 10 minutes later after the screen had turned off, I went to use the OS again but instead of the kde desktop I was presented with a screen full of glitchy colours as if it had crashed but still had mouse pointer.

At this point only option was to do ctrl alt f3 to get to a console.

Any suggestions??

That sounds line the automatic suspend that occurs after a short time with the system idle.

Maybe this will help.

It sounds like there might be an issue with the display driver or graphics settings. Here are some suggestions to troubleshoot the problem:

  1. Update Graphics Drivers: Ensure that your graphics drivers are up to date. You can check for updates using Fedora’s package manager (dnf).
  2. Check Xorg Configuration: Review the Xorg configuration files (/etc/X11/xorg.conf or /etc/X11/xorg.conf.d/*) to ensure they are configured correctly for your graphics hardware.
  3. Reset KDE Settings: Try resetting KDE to its default settings. You can do this by removing or renaming the KDE configuration directory (~/.kde or ~/.config/plasma*) and then logging in again.
  4. Check System Logs: Look for any error messages or warnings related to the graphics driver or Xorg in the system logs (/var/log/Xorg.*.log or /var/log/messages).

may be it will work for you.

Best Regard
Danish Hafeez | QA Assistant
ictinnovations.com

Was using wayland when it happened. Did a sudo dnf - - refresh upgrade but surprisingly few updates. Maybe some extra repositories I’ve not enabled, will have to check.

Rebooted after update, see if issue still exists.

1 Like