CPU temperature raises high while DNF UPDATE, Fedora34


I run a notebook with Fedora 34, actually Kernel Linux 5.12.11-300.fc34.x86_64 x86_64 and a processor ‘Intel Core™ i7-10750H CPU @ 2.60GHz × 12’. Usually the processor runs with a temparatur betweem 50-55 ° Celsius. But when I run a DNF UPDATE, even for small packages, the temperature quickly raises to about 90-95 ° Celsius and the fan runs at high speed. After DNF UPDATE ends then it takes a minute until the processor is at low temperature again.
What causes this? Do I have a chance to prevent this high temperature?

Thanyk you

Usually high temperatures are an indicator of insufficient cooling. Either your fan’s cooling body is not making good contact with the cpu or the fan duct is clogged, or your fan speed is not controlled adequately.


Hi Florian,

the notebook is pretty new, so I doubt that this behaviour is caused by the hardware (only). Again: I see the high temperature/fan only when using dnf, no matter if I run it via command or via the dnfdragora gui. Esp. when dnf is ‘applying changes to the system’ the temperature rises high. Any other command or application that I can run for testing purposes to see it this is only caused by dnf?

Thank you.

you might try “stress” to run the cpu under load for a time and see what happens.

You can also potentially install lm_sensors and gkrellm to allow continuous monitoring of the system sensors and see in real time what is happening.

1 Like

how best to stress the cpu? I have no idea…

Here is one of many examples: https://www.tecmint.com/linux-cpu-load-stress-test-with-stress-ng-tool/

The command to install the utility is

sudo dnf install stress

To run the stress command, use

sudo stress --cpu  8 --timeout 30 

(timeout can be changed).

While running the stress test, you can monitor your fan speed and core temperatures in another terminal window using:

watch -n 2 -d sensors

(sudo dnf install lm_sensors as @computersavvy pointed out, if not yet installed)

What’s the make and model? Maybe others with the same machine have some more insight. Could be too new…?! Are the fans spinning up, when the load increases? Is the BIOS firmware up to date?

1 Like

I was not aware of ‘stress’. I installed and ran it for 30 seconds. Everything worked as expected: cpu temperature raised to 90° celsius, fans ran at 70-80%, and after the 30 seconds test it took just 10 seconds until cpu temperature came down to 50° celsius and fan at 10%. Seems to be fine for my part. So a highly assume a bug in dnf that stresses the cpu.

1 Like

I don’t think it is a bug. Dnf does use a lot of cpu during the actual update while unpacking and installing the packages after the download part is complete. If the update is large it can be seen with cpu temps.


you could, as a workaround, try to disable delta rpms. that will cause larger downloads but less load on the CPU.



Anyways, especially with a new machine, the fan should be able to keep the temperature lower that what you report. Maybe update your BIOS firmware and your system, maybe some hardware is not yet fully supported by the kernel?

BTW, dnf keeps my CPU busy as well, but the temperature never rises above 74C. (oldish Thinkpad T440s)

1 Like

I use a notbook esp. manufactured for Linux: TUXEDO Polaris 17 - Gen1

Again, DNF is the only application that stresses its CPUs. Luckily when I recently upgraded to 5.12.13-300.fc34.x86_64 the cpu temperature did not raise above 65 °C and fan ran low.
I will keep this open and double check with the next kernel upgrade.

1 Like

I just detected that the temperature increases differently depending on the power supply. I tested with stress command: [jojo@fedora ~]$ sudo stress --cpu 12 --timeout 30

In case I run my laptop using battery the CPU temperature the temperature increases about 20 ° C only (from approx. 45° to 65° C) .
In case I run my laptop with power supply the temperature increases about 40-45°C! Strange enough (from approx. 45° up to 85° C). What might cause the different behaviour?

1 Like

CPU speed.
The cpu is normally throttled when it is running on battery to extend battery life, but is not limited when the power supply is attached.


following commands will give you some information about governors available.

cpupower frequency-info --governors
cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
1 Like

thany you all hints!

Command ‘cpupower’ can not be found. I checked the repositories, but n/a. But:

[jojo@fedora ~]$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

I need to correct: saw that cpupower is part of kernel-tools. After having installed I get:

[jojo@fedora ~]$ cpupower frequency-info --governors
analyzing CPU 0:
  available cpufreq governors: performance powersave

I would like to proceed with this issue because I get too often

fedora kernel: thermal thermal_zone0: acpitz: critical temperature reached, shutting down

This happens while using dnf, no matter via command or dnfdragora dialog. This time the shutdown started in between the

sudo dnf update

Any chance to limit dnf stressing the cpu?
Remark: I wonder why the cpu frequency is permantently on ‘powersave’. Also running the notebook connect to a power supply I have never seen ‘performance’. Why causes the switch from powersave to performance and vice versa?

Thank you

Dnf is not “stressing” the cpu per se.
I think, from reading this again, that your issue is likely inadequate cooling and that anything that causes the cpu to work will overheat it.

I seem to recall this is a laptop, and the suggestion has been made to open it up and clean the fans and air passages. If you do not do that (or have someone with the skills to do so do so) then the problem will only get worse. Beating your head against a brick wall hurts, and not fixing the problem properly has the same effect.

So far you have been lucky in that the high temp shutdowns have not occurred in such a manner as to corrupt the file system, but it is only a matter of time until it happens while writing and it does.


Sorry for jumping in this thread. But I have a similar issue with my laptop HP ZBook 15 G6 (from 2020) that started recently. I am running Fedora 34 (kernel 5.13.9-200.fc34.x86_64).

I have made sure to clean any dust in the laptop by opening it. When I use the command stress as shown before my computed shut down. But only if the power supply is plugged in.

@desperado: Did you manage to fix your issue?

For what is worth, my computer was off for the summer break (July month) and when going back on the computer I have updated the machine (installing the new kernel 5.13.6 from 5.12.11) and the overheating issues started from that moment.

Actually my issue is not fixed. I still try to figure out whether is is just DNF combined with kernel 5.13 that stresses the cpu. While my notebook is on power supply I can run

[jojo@fedora ~]$ sudo stress --cpu 12 --timeout 60
stress: info: [102158] dispatching hogs: 12 cpu, 0 io, 0 vm, 0 hdd
stress: info: [102158] successful run completed in 60s

with no emergency shutdown, maximum temperature is 95° Celsius for seconds, but most of the time about 85-90° celsius.

Because DNF UPDATE in the only item that causes the notebook to perform the emergency shutdown I circumvent by limiting DNF UPDATE (after having set SU), e.g.;

systemd-run --scope -p CPUQuota=20% dnf update

This allow to run DNF in the shell with limited cpu usage (e.g. 20%).

Actually I am looking for additional test programs that might stress cpu and graphics cpu. I still want to figure our if my issue is related to kernel 5.13 and DNF.

additional information: I doubt this might be caused by dust or dirty fans. The notebook was manufactured only 4 months ago and is stored at a clean place.