CoreOS cannot be upgraded anymore because wget/wget2

The second time in 6 weeks CoreOS doesnt update itself.

First time was this issue at CoreOS cannot be upgraded anymore because wget/wget2.

Now it cannot be upgraded because a cockpit-selinux issue:

After removing it the update went well but now i cant install it again:

rpm-ostree install cockpit-selinux

Checking out tree a65ed05... done
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora updates-archive
Importing rpm-md... done
rpm-md repo 'fedora-cisco-openh264' (cached); generated: 2024-03-12T11:45:42Z solvables: 3
rpm-md repo 'updates' (cached); generated: 2024-06-26T01:47:21Z solvables: 19546
rpm-md repo 'fedora' (cached); generated: 2024-04-14T18:51:11Z solvables: 74881
rpm-md repo 'updates-archive' (cached); generated: 2024-05-22T01:41:39Z solvables: 13161
Resolving dependencies... done
error: Could not depsolve transaction; 1 problem detected:
 Problem: conflicting requests
  - package cockpit-selinux-318-1.fc40.noarch from updates requires setroubleshoot-server >= 3.3.3, but none of the providers can be installed
  - package cockpit-selinux-314-1.fc40.noarch from fedora requires setroubleshoot-server >= 3.3.3, but none of the providers can be installed
  - package cockpit-selinux-315-1.fc40.noarch from updates-archive requires setroubleshoot-server >= 3.3.3, but none of the providers can be installed
  - package cockpit-selinux-316-1.fc40.noarch from updates-archive requires setroubleshoot-server >= 3.3.3, but none of the providers can be installed
  - package setroubleshoot-server-3.3.33-1.fc40.x86_64 from fedora requires libxml2-python3, but none of the providers can be installed
  - package python3-libxml2-2.12.8-1.fc40.x86_64 from updates requires libxml2(x86-64) = 2.12.8-1.fc40, but none of the providers can be installed
  - package python3-libxml2-2.12.5-1.fc40.x86_64 from fedora requires libxml2(x86-64) = 2.12.5-1.fc40, but none of the providers can be installed
  - package python3-libxml2-2.12.6-1.fc40.x86_64 from updates-archive requires libxml2(x86-64) = 2.12.6-1.fc40, but none of the providers can be installed
  - cannot install both libxml2-2.12.8-1.fc40.x86_64 from updates and libxml2-2.12.7-1.fc40.x86_64 from @System
  - cannot install both libxml2-2.12.5-1.fc40.x86_64 from fedora and libxml2-2.12.7-1.fc40.x86_64 from @System
  - cannot install both libxml2-2.12.6-1.fc40.x86_64 from updates-archive and libxml2-2.12.7-1.fc40.x86_64 from @System

rpm-ostree status

State: idle
AutomaticUpdatesDriver: Zincati
  DriverState: active; trying to stage 40.20240602.3.0 (failed attempts: 5)
Deployments:
● fedora:fedora/x86_64/coreos/stable
                  Version: 40.20240519.3.0 (2024-06-04T23:21:15Z)
               BaseCommit: 724ce262d4a27f6b7cb1508e8737e2244d69bb78509d2749cebd7972042bf814
             GPGSignature: Valid signature by 115DF9AEF857853EE8445D0A0727707EA15B79CC
          LayeredPackages: cockpit-networkmanager cockpit-ostree cockpit-packagekit cockpit-pcp cockpit-podman cockpit-selinux cockpit-storaged
                           cockpit-system cockpit-ws podman-compose

  fedora:fedora/x86_64/coreos/stable
                  Version: 40.20240504.3.0 (2024-05-20T18:00:04Z)
               BaseCommit: 72cf2f80ba1496d478e110d03e1199d9d21382840e96ffeddf4303eb040fbb55
             GPGSignature: Valid signature by 115DF9AEF857853EE8445D0A0727707EA15B79CC
          LayeredPackages: cockpit-networkmanager cockpit-ostree cockpit-packagekit cockpit-pcp cockpit-podman cockpit-selinux cockpit-storaged
                           cockpit-system cockpit-ws podman-compose

So the first sentence at CoreOS Website is misleading?

A minimal OS with automatic updates. Scalable and secure.

It should be “…with automatic updates that will work on 3 of 5 times, for the other updates you should spend time, investigate the net for solutions, stop services, uninstall packages that come from the same distributor, hope that it works after a reboot und then go and investigate why you cant install the removed packages again. If you switched from Ubuntu to CoreOS you should think about it twice because you will need more time to update CoreOS than Ubuntu. So your advantages are… nothing”.

It looks like it can not find a valid dependency resolution with what’s in the repos.

Can you make sure that the fedora-updates-archive repo is enabled? (/etc/yum.repos.d/fedora-updates-archive.repo)

I understand that this kind of situation can be frustrating. However, this is the trade off that comes with packages layering: we can not test all possible combinaisons of packages that you may install on your system. We can only test that the default image that we provide can update.

Once you start layering packages, you deviate from what’s tested automatically in CI and it’s on you to make sure that automatic updates still go through.

1 Like

According to

deleting cached rpm repo metadata by sudo rpm-ostree cleanup --repomd should probably resolve the issue.

1 Like

try again now… basically the archive repo manager VM sometimes just becomes unresponsive (and thus not continuing to populate the archive repo) and I don’t know why. We probably need to look into alerting when it’s not processing so we can A put it back in service faster and B further diagnose the issue.

1 Like