CoreOS cannot be upgraded anymore because wget/wget2

Hi,

according the discussion at https://www.reddit.com/r/Fedora/comments/1cf5jpu/switching_from_wget_to_wget2_suddenly_in_fedora/ they switched from wget to wget2.

I found out that some of our CoreOS servers will not update automatically anymore, and even manual updates are not possible anymore.

Has someone tipps, how i should proceed?

  • currently running: 39.20240407.3.0 (fedora:fedora/x86_64/coreos/stable)
  • available upgrade: 40.20240416.3.1 (fedora:fedora/x86_64/coreos/stable)
root@static:~# rpm-ostree upgrade --reboot
2 metadata, 0 content objects fetched; 788 B transferred in 2 seconds; 0 bytes content written
Checking out tree fb67df5... done
Enabled rpm-md repositories: fedora-cisco-openh264 updates fedora updates-archive
Importing rpm-md... done
rpm-md repo 'fedora-cisco-openh264' (cached); generated: 2023-12-11T14:43:50Z solvables: 4
rpm-md repo 'updates' (cached); generated: 2024-05-13T01:54:09Z solvables: 12780
rpm-md repo 'fedora' (cached); generated: 2024-04-14T18:51:11Z solvables: 74881
rpm-md repo 'updates-archive' (cached); generated: 2024-05-14T01:43:28Z solvables: 11711
Resolving dependencies... done
error: Could not depsolve transaction; 1 problem detected:
 Problem: conflicting requests
  - package wget2-wget-2.1.0-8.fc40.x86_64 from fedora requires wget2(x86-64) = 2.1.0-8.fc40, but none of the providers can be installed
  - package wget2-wget-2.1.0-9.fc40.x86_64 from updates-archive requires wget2(x86-64) = 2.1.0-9.fc40, but none of the providers can be installed
  - package wget2-2.1.0-8.fc40.x86_64 from fedora requires wget2-libs(x86-64) = 2.1.0-8.fc40, but none of the providers can be installed
  - package wget2-2.1.0-9.fc40.x86_64 from updates-archive requires wget2-libs(x86-64) = 2.1.0-9.fc40, but none of the providers can be installed
  - package wget2-libs-2.1.0-8.fc40.x86_64 from fedora requires libgnutls-dane.so.0()(64bit), but none of the providers can be installed
  - package wget2-libs-2.1.0-8.fc40.x86_64 from fedora requires libgnutls-dane.so.0(DANE_0_0)(64bit), but none of the providers can be installed
  - package wget2-libs-2.1.0-9.fc40.x86_64 from updates-archive requires libgnutls-dane.so.0()(64bit), but none of the providers can be installed
  - package wget2-libs-2.1.0-9.fc40.x86_64 from updates-archive requires libgnutls-dane.so.0(DANE_0_0)(64bit), but none of the providers can be installed
  - package gnutls-dane-3.8.5-1.fc40.x86_64 from updates requires gnutls(x86-64) = 3.8.5-1.fc40, but none of the providers can be installed
  - package gnutls-dane-3.8.5-1.fc40.x86_64 from updates-archive requires gnutls(x86-64) = 3.8.5-1.fc40, but none of the providers can be installed
  - package gnutls-dane-3.8.3-2.fc40.x86_64 from fedora requires gnutls(x86-64) = 3.8.3-2.fc40, but none of the providers can be installed
  - cannot install both gnutls-3.8.5-1.fc40.x86_64 from updates and gnutls-3.8.4-1.fc40.x86_64 from @System
  - cannot install both gnutls-3.8.3-2.fc40.x86_64 from fedora and gnutls-3.8.4-1.fc40.x86_64 from @System
  - cannot install both gnutls-3.8.5-1.fc40.x86_64 from updates-archive and gnutls-3.8.4-1.fc40.x86_64 from @System
1 Like

We need the output of rpm-ostree status.
Can you try resetting your overlayed packages and then re-installing them?

We need the output of rpm-ostree status.

root@static:~# rpm-ostree status
State: idle
AutomaticUpdatesDriver: Zincati
  DriverState: active; trying to stage 40.20240416.3.1 (failed attempts: 6)
Deployments:
● fedora:fedora/x86_64/coreos/stable
                  Version: 39.20240407.3.0 (2024-04-19T18:34:05Z)
               BaseCommit: 4f5997a887d92f19f6ce564069511115138916a37d7b30e2bfd027c5e5158e63
             GPGSignature: Valid signature by E8F23996F23218640CB44CBE75CF5AC418B8E74C
          LayeredPackages: cockpit-networkmanager cockpit-ostree cockpit-packagekit cockpit-pcp cockpit-podman
                           cockpit-selinux cockpit-storaged cockpit-system cockpit-ws podman-compose wget

  fedora:fedora/x86_64/coreos/stable
                  Version: 39.20240322.3.1 (2024-04-09T16:43:21Z)
               BaseCommit: 70c68b3d14b27e64bab4cb05a407e35472d172eda97be0f96b1e33cd65f6fd3b
             GPGSignature: Valid signature by E8F23996F23218640CB44CBE75CF5AC418B8E74C
          LayeredPackages: cockpit-networkmanager cockpit-ostree cockpit-packagekit cockpit-pcp cockpit-podman
                           cockpit-selinux cockpit-storaged cockpit-system cockpit-ws podman-compose wget

Can you try resetting your overlayed packages and then re-installing them?

I did now a rpm-ostree uninstall wget followed by systemctl reboot and now it works. It updated itself and restarted without errors.

Thanks for your input.

1 Like