COPR custom kernel install not showing up in GRUB

Hey folks,

I’m new to messing with custom kernels and I’m trying to install gloriouseggrolls fsync enabled kernel from the copr. After enabling the repo, I followed the instructions in the description by appending exclude=kernel* to /etc/yum.repos.d/fedora-updates.repo, doing a sudo dnf update --refresh followed by sudo dnf distro-sync.

According to the dnf logs it did install and downgrade to the new kernel, but upon rebooting I don’t have the option to boot from the newly installed kernel in grub. I ran sudo grub2-mkconfig but that didn’t help either. The new kernel is also not in /boot.

I did a sudo find / -iname '*5.9.11-fsync*' as well and I think I found it in /usr/src/kernels/5.9.11-fsync.301.fc33.x86_64, although I’m not entirely sure what I’m looking at when it comes to kernels, or if it’s just the headers that live there. Seems to be the only place where the find command succeeded at least.

My search-engine skills don’t seem up to par for this, so here we are! Any idea what to do to get the new kernel to show up in grub? Let me know if you need more logs, I’m not really sure where I could find other relevant log entries to debug this.

Thans in advance!

/var/log/dnf.log snippet
2021-01-19T13:16:14+0000 INFO --- logging initialized ---
2021-01-19T13:16:14+0000 DDEBUG timer: config: 2 ms
2021-01-19T13:16:14+0000 DEBUG Loaded plugins: builddep, changelog, config-manager, copr, debug, debuginfo-install, download, generate_completion_cache, needs-restarting, playground, repoclosure, repodiff, repograph, repomanage, reposync
2021-01-19T13:16:14+0000 DEBUG DNF version: 4.5.2
2021-01-19T13:16:14+0000 DDEBUG Command: dnf distro-sync 
2021-01-19T13:16:14+0000 DDEBUG Installroot: /
2021-01-19T13:16:14+0000 DDEBUG Releasever: 33
2021-01-19T13:16:14+0000 DEBUG cachedir: /var/cache/dnf
2021-01-19T13:16:14+0000 DDEBUG Base command: distro-sync
2021-01-19T13:16:14+0000 DDEBUG Extra commands: ['distro-sync']
2021-01-19T13:16:14+0000 DEBUG User-Agent: constructed: 'libdnf (Fedora 33; workstation; Linux.x86_64)'
2021-01-19T13:16:14+0000 DEBUG repo: using cache for:
2021-01-19T13:16:14+0000 DEBUG using metadata from Tue 19 Jan 2021 07:42:46 GMT.
2021-01-19T13:16:14+0000 DEBUG repo: using cache for: fedora-cisco-openh264
2021-01-19T13:16:14+0000 DEBUG fedora-cisco-openh264: using metadata from Tue 25 Aug 2020 20:10:34 BST.
2021-01-19T13:16:14+0000 DEBUG repo: using cache for: fedora-modular
2021-01-19T13:16:14+0000 DEBUG fedora-modular: using metadata from Tue 20 Oct 2020 00:04:43 BST.
2021-01-19T13:16:14+0000 DEBUG repo: using cache for: updates-modular
2021-01-19T13:16:14+0000 DEBUG updates-modular: using metadata from Fri 15 Jan 2021 00:29:37 GMT.
2021-01-19T13:16:14+0000 DEBUG repo: using cache for: updates
2021-01-19T13:16:14+0000 DEBUG updates: using metadata from Tue 19 Jan 2021 02:15:00 GMT.
2021-01-19T13:16:15+0000 DEBUG repo: using cache for: fedora
2021-01-19T13:16:15+0000 DEBUG fedora: using metadata from Tue 20 Oct 2020 00:27:19 BST.
2021-01-19T13:16:15+0000 DEBUG repo: using cache for: rpmfusion-free-updates
2021-01-19T13:16:15+0000 DEBUG rpmfusion-free-updates: using metadata from Sat 16 Jan 2021 00:12:25 GMT.
2021-01-19T13:16:15+0000 DEBUG repo: using cache for: rpmfusion-free
2021-01-19T13:16:15+0000 DEBUG rpmfusion-free: using metadata from Fri 16 Oct 2020 18:39:10 BST.
2021-01-19T13:16:15+0000 DEBUG repo: using cache for: rpmfusion-nonfree-updates
2021-01-19T13:16:15+0000 DEBUG rpmfusion-nonfree-updates: using metadata from Sat 16 Jan 2021 00:34:41 GMT.
2021-01-19T13:16:15+0000 DEBUG repo: using cache for: rpmfusion-nonfree
2021-01-19T13:16:15+0000 DEBUG rpmfusion-nonfree: using metadata from Fri 16 Oct 2020 19:04:38 BST.
2021-01-19T13:16:15+0000 DEBUG repo: using cache for: gitlab.com_paulcarroty_vscodium_repo
2021-01-19T13:16:15+0000 DEBUG gitlab.com_paulcarroty_vscodium_repo: using metadata from Tue 19 Jan 2021 03:06:22 GMT.
2021-01-19T13:16:15+0000 DEBUG repo: using cache for: WineHQ
2021-01-19T13:16:15+0000 DEBUG WineHQ: using metadata from Fri 15 Jan 2021 20:10:54 GMT.
2021-01-19T13:16:15+0000 INFO Last metadata expiration check: 0:00:06 ago on Tue 19 Jan 2021 13:16:09 GMT.
2021-01-19T13:16:15+0000 DDEBUG timer: sack setup: 1470 ms
2021-01-19T13:16:15+0000 DEBUG Completion plugin: Generating completion cache...
2021-01-19T13:16:16+0000 DEBUG Excludes in repo updates: kernel*
2021-01-19T13:16:16+0000 DEBUG --> Starting dependency resolution
2021-01-19T13:16:16+0000 DEBUG ---> Package kernel-headers.x86_64 5.9.11-fsync.301.fc33 will be a downgrade
2021-01-19T13:16:16+0000 DEBUG ---> Package kernel-devel.x86_64 5.9.11-fsync.301.fc33 will be installed
2021-01-19T13:16:16+0000 DEBUG --> Finished dependency resolution
2021-01-19T13:16:16+0000 DDEBUG timer: depsolve: 48 ms
2021-01-19T13:16:16+0000 INFO Dependencies resolved.
2021-01-19T13:16:16+0000 INFO ==============================================================================================================================================================================================================================================
 Package                                         Architecture                            Version                                                 Repository                                                                              Size
Installing dependencies:
 e[1me[32mkernel-devel                                   e(Be[m x86_64                                  5.9.11-fsync.301.fc33                                                            13 M
 e[1me[32mkernel-headers                                 e(Be[m x86_64                                  5.9.11-fsync.301.fc33                                                           1.2 M

Transaction Summary
Install    1 Package
Downgrade  1 Package

2021-01-19T13:16:16+0000 INFO Total download size: 15 M
2021-01-19T13:16:23+0000 INFO Downloading Packages:
2021-01-19T13:16:29+0000 INFO ----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
2021-01-19T13:16:29+0000 INFO Total                                                                                                                                                                                                         2.3 MB/s |  15 MB     00:06     
2021-01-19T13:16:29+0000 CRITICAL Importing GPG key 0x61A886F5:
 Userid     : "gloriouseggroll_kernel (None) <>"
 Fingerprint: 7571 34A9 F825 682B 0F55 AFF4 0C7D ADE8 61A8 86F5
 From       :
2021-01-19T13:16:32+0000 INFO Key imported successfully
2021-01-19T13:16:32+0000 INFO Running transaction check
2021-01-19T13:16:32+0000 INFO Transaction check succeeded.
2021-01-19T13:16:32+0000 INFO Running transaction test
2021-01-19T13:16:32+0000 INFO Transaction test succeeded.
2021-01-19T13:16:32+0000 DDEBUG timer: transaction test: 508 ms
2021-01-19T13:16:32+0000 INFO Running transaction
2021-01-19T13:16:32+0000 DDEBUG RPM transaction start.
2021-01-19T13:16:46+0000 DDEBUG RPM transaction over.
2021-01-19T13:16:46+0000 DDEBUG timer: verify transaction: 317 ms
2021-01-19T13:16:46+0000 DDEBUG timer: transaction: 13823 ms
2021-01-19T13:16:46+0000 DEBUG Completion plugin: Generating completion cache...
2021-01-19T13:16:46+0000 INFO 


2021-01-19T13:16:46+0000 INFO Complete!
2021-01-19T13:16:46+0000 DDEBUG Cleaning up.
2021-01-19T13:16:46+0000 DDEBUG /var/cache/dnf/ removed
2021-01-19T13:16:46+0000 DDEBUG /var/cache/dnf/ removed
ls -la /usr/src/kernels/5.9.11-fsync.301.fc33.x86_64
ls -la /usr/src/kernels/5.9.11-fsync.301.fc33.x86_64/
total 7016
drwxr-xr-x. 1 root root     330 Jan 19 13:16 .
drwxr-xr-x. 1 root root     100 Jan 19 13:16 ..
drwxr-xr-x. 1 root root     244 Jan 19 13:16 arch
drwxr-xr-x. 1 root root      80 Jan 19 13:16 block
drwxr-xr-x. 1 root root      30 Jan 19 13:16 certs
-rw-r--r--. 1 root root  226858 Dec  1 04:37 .config
drwxr-xr-x. 1 root root      76 Jan 19 13:16 crypto
drwxr-xr-x. 1 root root      88 Jan 19 13:16 Documentation
drwxr-xr-x. 1 root root    1408 Jan 19 13:16 drivers
drwxr-xr-x. 1 root root     872 Jan 19 13:16 fs
drwxr-xr-x. 1 root root     312 Jan 19 13:16 include
drwxr-xr-x. 1 root root      30 Jan 19 13:16 init
drwxr-xr-x. 1 root root      16 Jan 19 13:16 ipc
-rw-r--r--. 1 root root     555 Dec  1 04:37 Kconfig
drwxr-xr-x. 1 root root     290 Jan 19 13:16 kernel
drwxr-xr-x. 1 root root     382 Jan 19 13:16 lib
-rw-r--r--. 1 root root   63269 Dec  1 04:37 Makefile
drwxr-xr-x. 1 root root      66 Jan 19 13:16 mm
-rw-r--r--. 1 root root 1504327 Dec  1 04:37 Module.symvers
drwxr-xr-x. 1 root root     780 Jan 19 13:16 net
drwxr-xr-x. 1 root root     406 Jan 19 13:16 samples
drwxr-xr-x. 1 root root    3756 Jan 19 13:16 scripts
drwxr-xr-x. 1 root root     204 Jan 19 13:16 security
drwxr-xr-x. 1 root root     220 Jan 19 13:16 sound
-rw-r--r--. 1 root root 5370074 Dec  1 04:37
drwxr-xr-x. 1 root root     348 Jan 19 13:16 tools
drwxr-xr-x. 1 root root      44 Jan 19 13:16 usr
drwxr-xr-x. 1 root root      28 Jan 19 13:16 virt
-rw-r--r--. 1 root root      41 Dec  1 04:37
1 Like

Upon further inspection only kernel-headers and kernel-devel installed, but the main kernel package is for some reason not in that repo, or at least dnf doesn’t see it if I list packages. Wonder if it’s just a buggy copr repo rather than a problem on my end. There’s a whole bunch of installable packages at least, but I’m not sure how to tell dnf to fetch them from the copr repo. Here’s the available packages I get from the repo from dnf list

dnf list exerpt
Available Packages
kernel.src                                                                                        5.9.11-fsync.301.fc33                                                        
kernel-cross-headers.x86_64                                                                       5.9.11-fsync.301.fc33                                                        
kernel-debug.x86_64                                                                               5.9.11-fsync.301.fc33                                                        
kernel-debug-core.x86_64                                                                          5.9.11-fsync.301.fc33                                                        
kernel-debug-debuginfo.x86_64                                                                     5.9.11-fsync.301.fc33                                                        
kernel-debug-devel.x86_64                                                                         5.9.11-fsync.301.fc33                                                        
kernel-debug-modules.x86_64                                                                       5.9.11-fsync.301.fc33                                                        
kernel-debug-modules-extra.x86_64                                                                 5.9.11-fsync.301.fc33                                                        
kernel-debug-modules-internal.x86_64                                                              5.9.11-fsync.301.fc33                                                        
kernel-debuginfo.x86_64                                                                           5.9.11-fsync.301.fc33                                                        
kernel-debuginfo-common-x86_64.x86_64                                                             5.9.11-fsync.301.fc33                                                        
kernel-headers.src                                                                                5.9.11-fsync.301.fc33                                                        
kernel-modules-internal.x86_64                                                                    5.9.11-fsync.301.fc33                                                        

Solved it. Kind of. The description in the COPR could be more verbose though. Strangely, neither sudo dnf repo-pkgs list all nor sudo dnf list --repo nor sudo dnf list kernel nor sudo dnf list kernel-core or any other components showed the kernel from the copr, nor did it install by simple means such as sudo dnf install kernel, but by chance I started typing sudo dnf install kernel and tabbed a couple times and voila, the respective kernel packages showed up in the autocomplete suggestions.

If anyone knows how to make them show up via dnf search or dnf list as well, I’d be more than happy to hear it for future reference. Anyway, using the autocomplete suggestions I installed the necessary kernel packages via sudo dnf install kernel-5.9.11-fsync.301.fc33.x86_64 kernel-core-5.9.11-fsync.301.fc33.x86_64 kernel-modules-5.9.11-fsync.301.fc33.x86_64 kernel-modules-extra-5.9.11-fsync.301.fc33.x86_64 and am now happily on 5.9.11-fsync.301.fc33.x86_64.

So if anyone in the future comes across this with their favorite search engine, there you go. Maybe someone who actually knows more than very basic dnf usage can shed more light on why the packages didn’t show with e.g. dnf list kernel or dnf search.

I don’t use this copr repo, but I think /usr/src usually means source code, so you are expected to compile your own kernel. (Or maybe the copr repo owner put a precomplied kernel somewhere?)
You can use rpm -ql <package> to find what file <package>has installed. With fedora distribution kernel:

$ rpm -ql kernel-core-5.10.7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.