Connectivity-check is not working

I just checked connectivity check does not work in fedora but it works in ubuntu i ran ubuntu and pass my wifi card directly to the vm and check it opened the login page of my isp which is not true for fedora i need to check that with other distros. What is the issue here with fedora.

Is it latest kernel 5.19.14-200-fc36.x86_64 ?


$ uname -r

$ means it should be executed as user don’t include this in command

try to rollback i mean change to previous kernel

if it work then that would mean that this kernel is defective
cause for me it wasn’t working too

If you can’t open that page, open a terminal and try to ping it. If that fails, try traceroute.

It is working on Fedora 36 KDE spin. I messed my wifi config to check and got “limited connectivity” right away.

Can you check your firewall config?

Just because you can’t bring up that page doesn’t mean that you can’t reach the router. That’s why I want you to try pinging it. Before we can fix the issue, we need to find out where it is. Trust me; I used to do this for a living.

Just to check, do you mean your “router” login or the ISP website?
If it is your router, try sudo nmap -A _gateway and check the results.

no this connectivity check is nothing to do with kernel it is actually maintained by networkmanager package is

$ rpm -qa | grep NetworkManager-config-connectivity-fedora

as you can see i have that package

i am fully uptodate till now

how can i can you provide a guide
i can open that page with manually going to the ip in my case
or last given public ip i have checked many thing but i dont know why it does not work.
if i just log out my android ios windows and ubuntu all prompt me to login with connectivity check but my system does not f36 and f37 same.

$ NetworkManager --print-config
# NetworkManager configuration: /etc/NetworkManager/NetworkManager.conf (lib: 20-connectivity-fedora.conf) (run: 15-carrier-timeout.conf)

# plugins=
# rc-manager=auto
# auth-polkit=true
# dhcp=internal
# iwd-config-path=


# backend=journal
# audit=false

# wifi.backend=wpa_supplicant

sorrry to hear about that
i am in gnome workstation of fedora 37

thanks i hope to get that fixed i just tried again and my fedora does not notify me but my android does notified and asked to logback in

$ ping -c 4 [logged out state]

$ ping -c 4 [logged in state]
PING ( 56(84) bytes of data.
64 bytes from ( icmp_seq=1 ttl=43 time=325 ms
64 bytes from ( icmp_seq=2 ttl=43 time=323 ms

64 bytes from ( icmp_seq=3 ttl=43 time=327 ms
64 bytes from ( icmp_seq=4 ttl=43 time=331 ms

--- ping statistics ---
4 packets transmitted, 4 received, 0% packet loss, time 3455ms

the only think i have altered that i have added dnsovertls from systemd-resolved
just check by commented out all changes and restarted while logged out it does not asked for log back in. When i open firefox as usual it ask me to log in but fedora does not even prompted me.

it is not my router for sure if that is the case then my other devices also cant access that

after logged out this are the results

$ ping
ping: Name or service not known
$ ping
ping: Name or service not known
$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=62 time=10.0 ms
64 bytes from icmp_seq=2 ttl=62 time=4.33 ms
64 bytes from icmp_seq=3 ttl=62 time=4.24 ms
64 bytes from icmp_seq=4 ttl=62 time=4.53 ms
64 bytes from icmp_seq=5 ttl=62 time=4.30 ms
64 bytes from icmp_seq=6 ttl=62 time=4.69 ms
--- ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5007ms

OK, we now know that the box you’re trying to reach is on the same network that you are because you can reach it by IP address and that address isn’t routable. You can’t, however, reach it by host name, which tells me that whatever is resolving local DNS for you isn’t working. Back when I was doing support for an ISP, that kind of thing was outside our responsibility, and I’m guessing that it’s the same here. If anybody else feels competent to chip in, feel free to do so!

1 Like

I agree.
The login page shown appears to be for logging in to the ISP.
This issue definitely seems related to dns.

My steps would be

  1. power off, wait a couple minutes, then power back on the router.
  2. Do the same for your PC
  3. Now test the connectivity.

Sometimes the router can get confused and fail to properly configure the clients, while a power cycle may fix that. I have seen similar things multiple times over the years and the router simply needed a reboot to reconnect properly to the ISP, following which everything was back to working properly. Rebooting the PC then gets the proper info when it reconnects.

Does not work.
I don’t understand my all devices are connected with same router at the same time fedora system can’t provide me the notification for login but my other devices prompt me and also ubuntu system given me that prompt to log in android does that immediately but fedora does not i think it is fedora specific issue.

Martin just rollback and wait for next kernel version
kernel 5.19.14 is so buggy

You have better cause you can use it somehow

for me even display res not working
I installed updates by accident now :frowning:
when booting (AFTER your OEM logo appear) click shift(it can be few times) you should see grub
something and menu you can navigate by up and down arrows and enter to confirm

but if this option conatins 5.19.12 then do not ran it iit can broke intel igpu
i recomment selecting second option from top

We need wait for 5.19.15 that was released yasterday

The OP’s problem likely unrelated to kernel version. 5.19.14 isn’t known to be particularily buggy.

and if that was the potentially dangerous 5.19.12?

ahh, yes sorry

I highly appreciate that your want to help.
But you need to read my reply i have already told you it is nothing to do with kernel at all.

This part is handled by network manager

Is the dns configuration the same between the different systems?
Have you tried switching to NetworkManger for dns vice systemd-resolved?