Connecting HDMI monitor with fedora 30 prevents booting

Howdy. I tried searching for discussions covering this but nothing seemed to match my specific case.

I recently upgraded to to Fedora 30 from an older 28 install. Prior to the upgrade I was using a newish Viewsonic monitor connected via HDMI without issue. After the upgrade, if the monitor is connected the system will boot to the point of showing the grub menu but once it proceeds past that I get a flashing cursor for a few seconds and then the system spontaneously reboots. This loop continues until I unplug the monitor or turn the machine off.

If I disconnect the monitor during boot and then reconnect it once I can hear the box starting to process startup scripts everything works as expected and I can log in without issue.

I have looked through the BIOS for anything HDMI related but have not seen anything obvious. Any suggestions on what could be causing this and why it started with Fedora 30?


Try to fetch the log for the boot affected by the issue:

sudo journalctl -b ID > boot.log

For the current boot ID is 0 or omitted, for the previous boot ID is -1 and so on.

1 Like

Thanks for the response.

As far as I can tell, the system is not getting far enough in the boot sequence for anything to get logged when the failure state happens. All I am seeing is the good boots.

Check the boot loader configuration:

cat /etc/default/grub 
1 Like

Well now I am confused even more. Removing “rhgb quiet” shows me boot up but it also appears to have solved the problem.

Could the splash screen be triggering a kernel panic for some reason?

The changes related to the boot process:

Troubleshooting the boot failures and the workarounds:

1 Like

Appreciate the pointers vgaetera.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.