Computer froze during upgrade; cannot login on any kernel

Dear all,

while upgrading (sudo dnf upgrade), I did some other work and my computer froze because of that other work (not because of the upgrade), so I had to restart it. However, this meant that the updates got interrupted during installation (download was already finished).

Now I cannot login anymore: after choosing the kernel and decrypting the harddrive, the computer gets stuck, see attached picture. Note that this problem occurs for all three kernels.
The kernels in question are 5.19.11-200.fc36.x86_64, 5.19.9-200.fc36.x86_64, 5.19.8-200.fc36.x86_64.

I also tried using the rescue mode ( Fedora Linux (0-rescue-4587bf2400a04cb5b6628369bfcb64a7) 35). There, I obtain the following errors:

I found this thread and tried to unlock succeeded in unlocking the root account (see below), however

  1. I couldn’t unlock the root account as I do not know how to find the root partition with sudo fdisk -l : there are two “candidate” partitions which are both 1G Linux filesystems and I do not know which one would be the root partition. And
  2. Even if I managed to unlock root account, I wouldn’t know what to do next.

EDIT: I did manage to unlock the root account in rescue mode. One thing I found is that the dnf command is not working:

[root@noname ~]# dnf
Traceback (most recent call last):
... stack ...
ImportError: /lib64/ file too short

I also get a similar warning when logging into the root account, sth. along the lines of Flatpak: .... file too short.

I checked expat:

# rpm -V expat
S.5......    /usr/bin/xmlwf
....L....    /usr/lib64/
S.5......  d /usr/share/doc/expat/Changes
..5......  l /usr/share/licenses/expat/COPYING
S.5......  d /usr/share/man/man1/xmlwf.1.gz
S.5......  d /usr/share/doc/expat/Changes
..5......  l /usr/share/licenses/expat/COPYING
S.5......  d /usr/share/man/man1/xmlwf.1.gz
S.5......    /usr/lib64/

According to the RPM man entry, the L entry for means a “readlink(2) path mismatch”. I do not really know what this means or what to do.

I saw somebody reinstall a package using rpm, see DNF Update fails: ImportError: /lib64/ file too short - #5 by chrisishere. However, I do not fully understand what I am doing right now and thus would not like to do sth wrong (especially in root mode).

Some parts of File System look like to be broken. If it is true, you need to reinstall OS through LiveCD after backup.

Anyway, what are programs concerned with the work? Even if you reinstall OS, proplem apps can take OS ruin again.

Hi, thanks for your reply! I indeed reinstall /root after not finding a solution to the problem.

The software causing the freeze is the standard GNOME Videos video player. Once I open a video with Videos, it freezes. In contrast, VLC works fine.