Complete noob, need help please

Lately I’ve been getting sick and tired of Windows’ crap, and decided to try to switch to Linux, but all I have been getting is grief from this. It’s just a bunch of tiny things stacked one after the other that are making me think twice, and I can’t for the life of me find fixes on the internet. So, I thought I’d try coming directly to you guys.

Before continuing, this is my setup, if it may be useful:
Samsung Odyssey G9 as main monitor
XP-Pen tablet as secondary monitor
GPU: RTX 3090
CPU: R9 5950X
Ram: 64GB

My issues:

  1. Upon installing, the first thing that I noticed was that my monitor, a Samsung Odyssey G9, is unable to do 240hz at its maximum resolution. Not a huge issue for me, because 120hz is enough, but it was the first thing I noticed.
  2. Then, a phantom monitor showed up. I don’t know what the heck it is, it’s just labeled as “unknown 13.3” and all I can do is disable it. It also appears to interfere with my G9, as I can’t set the G9 to 120hz until after the phantom has been disabled.
  3. Then I noticed that my monitors never actually turn off when timed out. The screen fades slowly until both monitors turn off, and then the G9 flickers back on, and the XP-Pen turns back on with it.
  4. Another minor one, but it appears that my drives unmount themselves after a restart. Steam can’t find my game library until I manually specify where it is again.

I’m super new to this stuff, so trying to fix this on my own has only aggravated me with no solutions. I’m hoping some of you might know what to do. If you have any ideas, I can provide whatever logs you may need so long as you can guide me on how to get to them.

Thank you for your time.

Hello @electroarc ! Welcome! I was a complete noob once and still am! :slight_smile: It can be challenging but always fun, specially with the great Fedora community that we have here and across…

So, first things, it might be worth checking to see if there are any updates so can you first try the following in Terminal

You can launch terminal but pressing Ctrl+Alt+T

Then the enter the below
sudo dnf --refresh upgrade
hit Enter


sudo dnf distro-sync

hit Enter

and let us know the results

I’m guessing that would be an auxiliary video output port?

Is the phantom device listed if you run the following command in a terminal?

(excerpted from the kernel mode setting page of the Arch wiki)

for p in /sys/class/drm/*/status; do con=${p%/status}; echo -n "${con#*/card?-}: "; cat $p; done

If so, you might be able to disable the phantom device/port by adding something like video=DP-1:d to your kernel command line (where DP-1 would be substituted with the port that you want to disable).

From what you have said I am guessing you have not installed the driver for your nvidia GPU.

First enable the rpmfusion repo through the gnome software app (third party repos)
Then install the nvidia driver

  1. Disable secure boot in the bios setup menu
  2. Install the nvidia driver with dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda
  3. Wait about 5 minutes for the driver to complete building, then reboot
  4. Confirm the drivers were built and loaded with lsmod | grep nvidia
    If that returns several lines with nvidia in them the drivers are properly built and functional.

If the drivers were already installed from rpmfusion then nvidia-smi should give you the version that is active. Current is 530.41.03

I cannot speak to the failure to function at 240hz, but you said 120hz is good enough.

Did you install steam as flatpak or from rpmfusion (rpmfusion-nonfree-steam repo). Steam works for me installed from rpmfusion.

Drives do not unmount themselves. Steam is a 32 bit app and may have trouble with configs, but the drive does not automatically unmount normally.


Ctrl+Alt+T doesn’t seem to open the terminal, but here’s the results from the commands:

johnm@fedora ~]$ sudo dnf --refresh upgrade
Copr repo for PyCharm owned by phracek 11 kB/s | 2.1 kB 00:00
Fedora 38 - x86_64 58 kB/s | 22 kB 00:00
Fedora 38 openh264 (From Cisco) - x86_64 3.1 kB/s | 989 B 00:00
Fedora Modular 38 - x86_64 51 kB/s | 21 kB 00:00
Fedora 38 - x86_64 - Updates 60 kB/s | 22 kB 00:00
Fedora Modular 38 - x86_64 - Updates 54 kB/s | 23 kB 00:00
google-chrome 4.7 kB/s | 1.3 kB 00:00
RPM Fusion for Fedora 38 - Nonfree - NVIDIA Dri 17 kB/s | 6.0 kB 00:00
RPM Fusion for Fedora 38 - Nonfree - Steam 16 kB/s | 5.7 kB 00:00
Dependencies resolved.
Nothing to do.
[johnm@fedora ~]$ sudo dnf distro-sync
Last metadata expiration check: 0:00:12 ago on Sun 23 Apr 2023 08:56:00 PM EDT.
Dependencies resolved.
Nothing to do.

It seems to just be listed as “Unknown 1”

[johnm@fedora ~]$ for p in /sys/class/drm//status; do con=${p%/status}; echo -n "${con#/card?-}: "; cat $p; done
Unknown-1: connected
DP-1: connected
DP-2: disconnected
DP-3: disconnected
HDMI-A-1: connected

I’m pretty sure they were installed from the Fedora software store app thing, but I ran it anyways.

This was the output:

[johnm@fedora ~]$ sudo lsmod | grep nvidia
nvidia_drm 94208 14
nvidia_modeset 1290240 3 nvidia_drm
nvidia_uvm 3219456 0
nvidia 55853056 261 nvidia_uvm,nvidia_modeset
video 77824 1 nvidia_modeset
[johnm@fedora ~]$ nvidia-smi
Sun Apr 23 21:03:00 2023
| NVIDIA-SMI 530.41.03 Driver Version: 530.41.03 CUDA Version: 12.1 |

All problems still persist. Phantom monitor is still there, and my G9 still can’t reach 240hz.

Also, new issue!
My PC seems to freeze at a grey screen maybe 1 out of 4 times when loading from a restart or shutdown.
Is that a known issue with a fix? I don’t even know how you’d get logs on that

In that case, you should be able to disable it automatically on boot by adding video=Unknown-1:d to the kernel command line. I think the following command might do what you need.

sudo grubby --update-kernel=ALL --args="video=Unknown-1:d"

There is more documentation on making changes to the grub2 bootloader configuration here.

1 Like

It’s not a problem I’ve heard of. However, you should be able to view the logs of the previous boot attempt with the following (-1 means the previous boot; 0 would be the current boot, -2 would be two boots prior, etc.).

sudo journalctl --boot=-1

Alright, that seems to have worked.
Phantom monitor no more!

Sorry, I was mistaken.
It wasn’t on boot, but it was logging in.
The OS seems to take a random frame from the boot process and flash it on the screen while logging me in. Sometimes it’s gray, and this time while trying to recreate the issue it was the line of text stating that Fedora was booting from before I got to the sign in screen.
The journalctl command doesn’t appear to show anything useful as it doesn’t actually happen on boot.

One thing I’m unsure of is if that command applies only to the currently installed kernels or to all kernels (current and future). If you find that the setting is lost after you update to a new kernel, a little more investigation might be required to make the setting more permanent.

I don’t know about the video problems on login. Sometimes the system will attempt to change the video mode or resolution right after logging in. But I don’t know where the logs would be if something is going wrong at that point. Does the service manager report any failed services? Use the following command to check.

systemctl --failed

If that doesn’t show anything, you might also check the “user” services with the following command.

systemctl --user --failed

Just posting to say I am having the same issue.


I have been able to come up with some solutions that might help (at least they worked for me). For reference:

CPU: Ryzen 7900x
GPU: RTX 3090
MB: Asus B650e-f
Monitor 1: MSI- 1440p, 144hz
Monitor 2: Acer- 1440p, 75hz
Monitor 3: Acer- 1440p, 170hz
DE: Gnome 44

So in my case, I am confident that the phantom monitor is related to my 7900x’s integrated graphics, or how the MB handles it. I found that when I disabled it in the bios, I would get the phantom monitor (as well as some really buggy behavior in Xorg sessions). Setting integrated graphics to “Auto” removed the phantom monitor and restored normal functionality in Xorg, to include being able to successfully change the refresh rates of my monitors and the primary monitor setting. I also found that I had to add nvidia_drm, nvidia_modset, nvidia_uvm, and nvidia to the initramfs configuration to have them properly start up and override the integrated graphics at boot. Before doing this I would get black screen at the encryption login prompt and poor resolution at the gdm login prompt.

I still need to test the boot and phantom monitor behavior with integrated graphics disabled WITH the kernel edits I made to see if the issue persists, but the system is at least usable in Xorg sessions now.

As far as the lock to 120hz refresh rate goes: I had this same problem in F37 after switching to my current system from one without integrated graphics but still the same Nvidia GPU, and still have it in F38. The difference is that in F37 attempting to change the refresh rate would result in “no signal” and in F38 it freezes whatever image is on the monitor. In both F37 and F38 I am locked to either 120hz or 59.95hz with those Acer monitors and any deviation results in those mentioned signal issues. It also only occurs in Wayland sessions, and only happens with my Acer monitors which register different available refresh rates in display settings as compared to my MSI (i.e. MSI-144hz vs Acer- 143.91).

But after spending 16+hours troubleshooting issues related to Nvidia proprietary drivers and F38, I will absolutely NEVER use an Nvidia graphics card on a linux workstation again. I have had issues in the past, but this takes the cake by a large margin.

So possible solutions:

Make sure your data is backed up somewhere first in case you need to reinstall from scratch

  1. Even though the 5950x does not have integrated graphics, maybe check you MB settings and see what the option is set to, or if there is an option to force PCI graphics/set PCI to primary graphics.

  2. Use Xorg instead of Wayland to fix refresh rate problem. You can do this by hitting the little settings cog in the bottom right of the initial login screen after you click on your username and select “Gnome on Xorg.” If your login screen is buggy, change #WaylandEnable=false to WaylandEnable=false in the /etc/gdm/custom.conf file which will force gdm to start in a Xorg session as opposed to Wayland which is the default.

  3. If you are having buggy boot problems, you may need to force the drivers to start earlier in the boot process by editing the kernel. This page from Arch wiki (and the associated pages) helped me: NVIDIA - ArchWiki

  4. For the solution above, assuming you have installed the proprietary Nvidia drivers you can edit the existing kernel’s initramfs configuration using this command: sudo dracut --force --force-drivers "nvidia nvidia_modeset nvidia_uvm nvidia_drm" but I recommend reading up on that wiki page and reading man dracut beforehand so you have an idea about what you are doing.

Finally if anyone has an idea about WTF is going on with Wayland + Nvidia + refresh rate issues on certain monitors, please help. I have been racking my brain on that problem for months now and haven’t been able to find a solution.

1 Like

It’s probably incorrect EDID information being returned from the monitor. There are guides online about how to manually supply a correct definition for what modes your monitor can support. But they are dangerous in that if you provide values beyond what your monitor can handle, you can fry your monitor.

Edit: I haven’t done it, but this site looks like a decent place to start if you want to risk it.

Found the solution (technically a work around) to phantom monitor: Proprietary Nvidia driver shows a black screen instead of a virtual terminal or a graphical session

Looks like the change to SimpleDRM + Nvidia drivers is to blame for the phantom monitor and the various reports of black screens at the LUKS prompt.

Working for me

1 Like

I’m new here, and do not use Linux in any form,… I happened to be researching the 57 inch ODYSSEY G9 monitors for an upgrade,… during my search,… I found that the 30 series NOR! the 40 series Nvidia are certified for FULL 7680 x 2160 at 240Hz ,. being locked as a result of not having, Displayport 2.1 certification and apparently,. the HDMI 2.1 isn’t sufficient ,… I HAVE! discovered that the 3090 CAN! run the 49 inch G9 at 5120x1440 +240Hz ,… I hope this information is helpful!

1 Like

Welcome and thanks for the information! :nerd_face: