Chromium/Electron desktopCapturer is limited in Wayland + how to undo NVIDIA kernel updates?

FYI I’ve tried Electron desktopCapturer (which is based on Chromium) and - in Wayland - it only works with Electron apps, it shows the mouse on a black screen, when trying to capture the “Entire Desktop”. Moving to Gnome X11 solves the issue as I explained here.

That having said, a quick question. I’ve tried to follow the instruction for NVidia driver update but it didn’t work probably because my Intel GPU is an old model: GT540M?

[giuliohome@localhost ~]$ screenfetch
           /:-------------:\          giuliohome@fedora
        :-------------------::        OS: Fedora 
      :-----------/shhOHbmp---:\      Kernel: x86_64 Linux 5.13.10-200.fc34.x86_64
    /-----------omMMMNNNMMD  ---:     Uptime: 48m
   :-----------sMMMMNMNMP.    ---:    Packages: 3214
  :-----------:MMMdP-------    ---\   Shell: bash 5.1.0
 ,------------:MMMd--------    ---:   Resolution: 2390x768
 :------------:MMMd-------    .---:   DE: GNOME 40.0
 :----    oNMMMMMMMMMNho     .----:   WM: Mutter
 :--     .+shhhMMMmhhy++   .------/   WM Theme: Adwaita
 :-    -------:MMMd--------------:    GTK Theme: Adwaita [GTK2/3]
 :-   --------/MMMd-------------;     Icon Theme: Adwaita
 :-    ------/hMMMy------------:      Font: Cantarell 11
 :-- :dMNdhhdNMMNo------------;       Disk: 633G / 912G (70%)
 :---:sdNMMMMNds:------------:        CPU: Intel Core i5-2430M @ 4x 3GHz [87.0°C]
 :------:://:-------------::          GPU: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)
 :---------------------://            RAM: 2586MiB / 7793MiB

Should I undo my changes to the kernel etc… since I always see “NVIDIA kernel module missing. Falling back to nouveau” and, just in case, how to do that?

1 Like

If you used RPM Fusion (as you should), it’s just one command:

1 Like