Chrome as default browser in KDE Plasma: Getting it to stick

This problem has been going on for YEARS, and I always end up having to lookup when I switch back and forth between Fx and Chrome. I just tried this method and it works great:
Chrome as default browser in KDE Plasma: Getting it to stick

Go ahead and chose “chromium” or “google-chrome” as the default browser in the “settings” application, and hit apply. That setting will likely stick, but Chrome will not be the default browser anyway. A bug in KDE Plasma prevents this, but you can drill down deeper into the configuration information and make it work:

Go to your settings tool.

Go to Configure File Associations

Filter the list for “html”

Find the entry for xhtml+xml and move “Chromium” or “Google Chrome” to the top of the list. If it doesn’t show up in the list, search for it and add it. It should now be at the top of the list. If not, move it there.

Do the same for “html”

Hit “apply.”