Change of display resolution made monitor to go in erroneous state and didn't display anything

Hi All,

I was using Fedora 30 from many days with my Dell P22217H monitor. The display resolution was set to 1920x1080 by default and refresh rate was 60.00 Hz and everything was fine until I started playing with resolution settings as below:

I changed my resolution from 1920x1080 to some other resolution maybe 1440x1080. What I didn’t noticed that time was that Refresh rate input field went away. Anyway I applied this new resolution.

After applying this new resolution I didn’t quite liked it so I changed back to my old resolution which was 1920x1080. But now when I changed resolution back to original what I didn’t noticed is that now refresh rate was set to 59.96 Hz. (This I am able to tell because I recreated this issue and now I noticed everything). Initially I didn’t noticed about refresh rate.

So once I changed the resolution back to 1920x1080 and clicked Apply. My Dell Monitor screen blacked out with a monitor in-built error message on the center of the screen saying “Please set the resolution to 1920x1080 and refresh rate to 60.00Hz”

But as now I don’t have access to GUI so I could not change resolution and refresh rate as suggested by Dell Monitor error message.

Also I tried restarting system but just the login screen GUI shows up properly and the moment I login my Dell Monitor displays same error with black screen. Now I just have access to the system command line terminal which I opened by pressing keys ALT +F2.

In the command line terminal xrandr command is also not working properly when I run it says it says cannot open display.

What I did now is I connected another same model Dell Monitor with my Fedora system and it works perfectly fine. The other monitor is having same brand and dimensions as my previous one. But the moment I connect my old monitor which I was using earlier it throws same error.

I tried running xrandr command while connecting to new monitor and followed steps mentioned in below thread answer but no luck still my old monitor won’t work:

There should be something to make it right from command line I believe. Its strange to see that other monitor with same specification is working.

Any help regarding this would be great.


Hi @motogeeeksatyam! Welcome to the community! Please do take a few minutes to go over the introductory posts in #start-here when you have the time. They contain lots of useful information.

Actually, it could be quite easy to resolve (and probably you’ve already resolved your issue, as more than a week has passed).

The monitor/display configuration in stored in a file ~/.config/monitors.xml. Just deleting this file should be enough to force gnome to use default settings, not previously saved ones.

I’ve used this file for another purpose (namely moving gdm login screen in a dual-monitor setup), but as far as I understand deleting it should help you.

There also should be ~/.config/monitors.xml~ (notice tilda) file, that’s a backup, which in you case should be your previous working settings. Another option should be copying the backup to monitors.xml – but it shouldn’t be needed, as without this file defaults (automatically detected to be bset for your monitor) will be used, and the file itself will be recreated when you change monitor/display settings in gnome’s settings.

1 Like