Can't upgrade to fedora 34

so, i’ve received the notification from the software center and downloaded the update, but when i try to install i get a “transaction error, file /usr/lib64/ from libhandy-1.2.1-2.fc34.x86_64 conflicts with the one from libhandy1-1.2.0-1.fc33.x86_64” and can’t progress

tried also with “sudo dnf install libhandy-1.2.1-2.fc34.x86_64 --releasever=34” but says the same exact thing, even with --skip-broken, --best and --allowerasing

any suggestions?cause it looks like i’m stuck here…

Try removing duplicates:

sudo dnf remove --duplicates

If the issue persists, remove the problematic package:

sudo rpm -q -a libhandy
sudo rpm --nodeps -e libhandy

Then proceed with CLI upgrade:
DNF System Upgrade :: Fedora Docs

1 Like

Tried with dnf remove libhandy, but says can’t remove the package due to gnome shell dependency, is this safer to do?

What if you do

sudo dnf system-upgrade download --releasever=34 --allowerasing --best


Note system-upgrade, not the individual package. (I’m not surprised that attempting to install just the individual package on a non-updated system does not work.)

1 Like

I’ll try that after lunch, thank you

What is the info for this package? That version does not exist in Fedora repos.

i have some problems with iptables then, and putting the skip-broken command does not help

as for info, how do i get that?

ok, tried the normal upgrade process, but at the end i got the same error for libhandy…

thinking about doing e reinstall…

You can remove the problematic package overriding its dependencies as mentioned above.

Nope, that removed the dependencies yes, but the problem still persisted…tried that…

Before going to a reinstall, the next thing I’d try is dnf distro-sync.


Post the exact error messages, otherwise no one can help you.


Sorry guys but i was too in a hurry and already reinstalled, i’ve been trying things from yesterday and nothing helped me so i decided to do a full reinstall

Thanks for your help anyway…

1 Like

For anyone else being blocked by iptables, there is an open bug and people are working on it. You can work around the problem for now by manually removing iptables and dependent packages (e.g. dnf remove iptables firewalld libvirt if you have these three) and reinstalling them and any other required package once the upgrade is complete.

You can just remove iptables since it should be replaced with nftables.

1 Like

I don’t think everything has moved to nftables yet, that’s why there’s an iptables-compat package.

iptables-compat is a dummy package.
iptables-nft will be reinstalled automatically on upgrade.

This is moot; the thing is that people who have upgraded from F32 or earlier will most likely have iptables on their systems and depending on the combination of installed packages, they might hit the same problem during the upgrade to F34.

Btw there’s another update:

Works fine for me, upgraded multiple hosts through several versions.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.