Can't upgrade system. rav1e-libs can't be removed

Problem

Running dnf upgrade, even with or without --allowerasing --best etc, is not allowing me to upgrade my system. Dnf is unable to replace/remove libimagequant i686 and rav1e-libs to allow the upgrade. The libimagequant-4.0.3-1.fc39.i686 I was able to uninstall vis dnf remove, but can’t do the same with rav1e-libs.

Cause

Trying to upgrade:

Error: Transaction test error:
file /usr/share/licenses/rav1e-libs/LICENSE.dependencies from install of rav1e-libs-0.6.6-4.fc39.x86_64 conflicts with file from package rav1e-libs-0.6.6-3.fc39.i686

Trying to remvoe rav1e-libs:

Error:
Problem: The operation would result in removing the following protected packages: gnome-shell
(try to add ‘–skip-broken’ to skip uninstallable packages)

Not yet known.

Related Issues

Workarounds

None yet.

You should be able to manually remove with rpm
sudo rpm -e rav1e-libs --nodeps

and then re-install
sudo dnf install rav1e-libs

1 Like

Thanks you kindly!
It solved it. Annoying to have to use another tool and the full new name of the package rav1e-libs-0.6.6-3.fc39.i686/rav1e-libs-0.6.6-3.fc39.x86_64