Can't update from F35 to F36!

I tried updating from the Software menu to F36, with the following error:
“Unable to upgrade to Fedora Linux 36:
Error running transaction: file /usr/share/doc/libxslt-devel-1.1.35-1.fc36.i686 and libxslt-devel-1.1.35-1.fc36.x86_64”

I’ve never had issues downloading new Fedora versions before so that’s why I am asking you for help. Thanks!

I saw a similar post on reddit:

The first poster seems to have a solution.

libxslt-devel is not a package that you probably need… or can’t just reinstall later. See if you can do a

sudo dnf erase libxslt-devel

see what that does for you.

might have to do something more drastic like

sudo rpm -qa | grep libxslt-devel

and the

sudo rpm -e --force the rpm packages that that grep statement returns.


This is sort of a bug because /usr/share/doc files should not be architecture dependent and so no conflict should occur.

A current workaround as @aegir81 noted, is to uninstall the package. Do you know why you have the i686 version of the package installed? Can you try removing it to see what you get?

sudo dnf remove libxslt-devel.i686

We shouldn’t need to do a rpm -e --force. Let’s see what we get via dnf and then we can think of next steps.


A post was split to a new topic: “Oh no, something has gone wrong” after upgrade

This sounds similar to the issues I’m having. Every time I try to install F36 it returns a transaction error like this:

Unable to upgrade to Fedora Linux 36:
Error running transaction: file /usr/share/ppd/Epson/epson-inkjet-printer-escpr/Epson-XP-960_Series-epson-escpr-en.ppd.gz conflicts between attempted installs of epson-inkjet-printer-escpr-1:1.7.18-1.1lsb3.2.fc36.i686 and epson-inkjet-printer-escpr-1:1.7.18-1.1lsb3.2.fc36.x86_64

I did have two printers installed so used the settings facility in Gnome to remove them. That made no difference. I then used Terminal to access /usr/share/ppd/ and deleted all references to Epson and HP whilst leaving the CUPS folder alone.

So far, no joy, and I cannot get it to upgrade to F36. Does anyone have any suggestions as to how I can eradicate any references to historical printers?

I would remove epson-inkjet-printer-escpr, retry the update.

dnf remove epson-inkjet-printer-escpr

Try the update, if it fails you should see a different error message.
Re-install epson-inkjet-printer-escpr if you need it.

dnf install epson-inkjet-printer-escpr

[root@rawhide rj]# dnf repoquery -f /usr/share/ppd/Epson/epson-inkjet-printer-escpr/Epson-XP-960_Series-epson-escpr-en.ppd.gz
Last metadata expiration check: 3:56:31 ago on Sat 11 Jun 2022 10:18:31 AM EDT.

1 Like

Thanks for that, it worked perfectly.


Totally agree. Using -e --force on rpm is risky, and especially without no-deps. Always, always, always try to make it work with dnf first.