Can't switch back to X11

Hey there,

I need to switch back to X11 in order for chrome screen sharing for MS Teams to start working again. Pretty annoying that M$ doesn’t support Firefox, which handles Pipewire Screen Sharing really well…

So recently maybe after upgrading to F35, I am unable to see the gear icon in gdm. Even if I manually disable wayland gdm just won’t be able to start and crash. Not even lightdm or startx work…

I suppose that’s nvidia driver related, since when I boot up an old kernel that has an older version of the nvidia in it’s initramfs, it will show me the gear icon and boot into Gnome on Xorg. The problem then is that the animations just get disabled like on llvmpipe and the dmesg output also suggests that the nvidia driver straight up refused to fully initialize. I unfortunately did not save the output, but will try and add it tomorrow.

One thing I suspected was that the xorg nvidia driver was missing but nope it’s installed. I have no idea what to try next. Hopefully one of you can help me, thank you!

xauth:  file /home/user/.serverauth.3511 does not exist

X.Org X Server 1.20.14
X Protocol Version 11, Revision 0
Build Operating System:  5.15.6-200.fc35.x86_64 
Current Operating System: Linux vbu-c-jlamp-02-li 5.15.12-200.fc35.x86_64 #1 SMP Wed Dec 29 15:03:38 UTC 2021 x86_64
Kernel command line: BOOT_IMAGE=(hd1,gpt2)/vmlinuz-5.15.12-200.fc35.x86_64 root=/dev/mapper/data-froot ro rootflags=subvol=@ resume=UUID=3ece1f9b-b4b9-4ca2-951a-98620f4f76f5 rd.luks.uuid=luks-a9f1baa2-fa74-4080-9435-8eaa724c4226 rhgb quiet rd.driver.blacklist=nouveau modprobe.blacklist=nouveau nvidia-drm.modeset=1
Build Date: 17 December 2021  12:00:00AM
Build ID: xorg-x11-server 1.20.14-1.fc35 
Current version of pixman: 0.40.0
	Before reporting problems, check
	to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/home/user/.local/share/xorg/Xorg.0.log", Time: Mon Jan 10 21:29:47 2022
(==) Using config directory: "/etc/X11/xorg.conf.d"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
(II) modeset(0): Initializing kms color map for depth 24, 8 bpc.
Fatal server error:
(EE) failed to create screen resources(EE) 
Please consult the The X.Org Foundation support 
 for help. 
(EE) Please also check the log file at "/home/user/.local/share/xorg/Xorg.0.log" for additional information.
(EE) Server terminated with error (1). Closing log file.
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=0 PID=3605
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-backup-logs.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-disable-guest.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-minimum-vt.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-run-directory.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-session-wrapper.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-user-authority-in-system-dir.conf
[+0.00s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/50-xserver-command.conf
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.00s] DEBUG: _g_io_module_get_default: Found default implementation local (GLocalVfs) for ?gio-vfs?
[+0.00s] DEBUG: Monitoring logind for seats
[+0.00s] DEBUG: New seat added from logind: seat0
[+0.00s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.00s] DEBUG: Seat seat0 has property CanMultiSession=no
[+0.00s] DEBUG: Seat seat0: Starting
[+0.00s] DEBUG: Seat seat0: Creating greeter session
[+0.00s] DEBUG: Seat seat0: Failed to find session configuration lightdm-greeter
[+0.00s] DEBUG: Seat seat0: Failed to create greeter session
[+0.00s] DEBUG: Failed to start seat: seat0

I already tried to reinstall the driver but that did not help either. Does anyone have any more suggestions?

Hi, since you’re still using gnome desktop please check /usr/share/xsessions. There should be 3 files inside it.

[testcase@fedora ~]$ ls /usr/share/xsessions/
gnome-classic.desktop  gnome.desktop  gnome-xorg.desktop

Those tree files are the menu you see in login to select the session.

According to this old discussion , when GDM is running under X11, then the option for “gnome on xorg” will be hidden on GDM.

I can check if my gnome is running on X11 or wayland by goto to “Settings \ About” From there, the Windowing System will show as X11 or Wayland respectively. You might be running gnome on X11 already.

Hm looks like it should, but they will only show up when switching back to nouveau:

$ ls /usr/share/xsessions/
gnome-classic.desktop  gnome.desktop  gnome-xorg.desktop  xinit-compat.desktop

Yeah true, had to get around that by editing udev rules in the past, but no I am on wayland

1 Like

Hi, if you’re still using lightdm, you could customize the pointing session directory.

# File `/etc/lightdm/lightdm.conf`


If you’re using gdm, you could disable the wayland.

# File /etc/gdm/custom.conf


Note: Please if you want to try above configs, make sure you know how to revert it back by booting to tty in case somethings goes wrong.

Guess I failed to mention that I tried that already. When disabling Wayland in gdm, it will fail to start. Lightdm won’t even start with the defaults.Guess it runs on X by default then. (Does lightdm even support Wayland?)

So there seems to be something really really wrong with either my setup or the damn Nvidia driver.

Lightdm it self, I believe run with X, but only on the login page. We still can login to wayland session (I have distro use lightdm with i3 and sway session).

Btw it’s weird. Nvidia driver should be better with xorg session by default. Maybe you need to find a config specific related to Nvidia with xorg. Let say config of xorg.conf or any related. I’ll check if I can get my old laptop with Nvidia GPU tonight.


@modzilla here a file /etc/X11/xorg.conf that if we don’t have it or have wrong config, the xorg session will not work. But we can regenerate this file with sudo nvidia-xconfig. Make sure to delete the old xorg.conf (or rename it as backup) to be able to create the new one.


Turn out @sampsonf was right, just switch back from sddm to gdm and the Gnome Xorg session menu was gone and by default if we choose the default one, Gnome, it will use Xorg session on my machine.

1 Like