Can't start after update

I did downgrtad it but nothing different.

What filesystem are you using? 5.9.9 - 5.9.10 had some XFS issues, which could definitely create problems, and using them to do an upgrade could be an issue, but that was fixed with 5.9.11. The issue would complain of fs corruption, but there was no actual corruption, so booting back into 5.9.8 or earlier, and then updating to 5.9.11 or newer should work. We are on 5.9.13 now, with 5.9.14 in updates testing. Does this still cause issues with either of these kernels?

I am using ext4 , df -T :
/dev/sda5 ext4 30935964 20062824 9278620 69% /
/dev/sda6 ext4 10255636 49128 9665836 1% /tmp
/dev/sda7 ext4 90286944 63626784 22030812 75% /home
/dev/sda2 vfat 98304 45271 53033 47% /boot/efi

now I am on 5.9.10-200 after update 5.8 was deleted and the new one does the same thing . here are my installed kernels:

I have the exact same problem on a Thinkpad T14 with kernel 5.10.12-200: Failed to start rule-based manager for Device Events and Files, and then it hangs. Is there a fix for this?

I installed F33 from a live usb with kernel 5.8.15-301, and that still boots fine.

Do you have dracut errors in your logs? @jforbes any further thoughts?

In my case, It disappeared after one update and reappeared after another one and so one. Just boot on the working kernel until the next update.
In another laptop I just reinstalled fedora 32 hoping this issue will be gone in F34

I hope so too but I’d rather find and fix the root cause :slight_smile:

Isn’t this because the installation is made with a root user without a password, instead a normal user set as admin alias inserted to the wheels group? If needed the root user and password can be set after installation.

As explained here:

Are you using a script to create the users wen installing a new laptop/computer? Or what is your procedure for that?

In my opinion this could be the missing “having in common” ?!

the first time I installed from lifeUSB, so after installation at the first restart a window will popup and ask me to create a user. I did it probably with Fedora 30 then upgraded every new fedora untill 33 when it started.
I tried installing F33 from liveUSB and the issue reappeared after update.

Ok, do you have the option to set this user with admin rights alias, is this user a sudo user?

I never paid attention. but what I can say is as soon as I am ready to use Fedora the first things I do are :
sudo -i
dnf remove sudo

I can’t do the dnf remove sudo

dnf remove sudo
Problem: The operation would result in removing the following protected packages: sudo
(try to add ‘–skip-broken’ to skip uninstallable packages)
[root@localhost luciano]# dnf remove sudo --skip-broken

I remember that i was giving my user sudo while installing. This means you can remove sudo because you are not a sudo user ?!

Interesting, you are able to install as root without pw and after you change the password of root to a new one.

I will try to reproduce your workflow on a libvirt installation,

I guess when I created the new user it was automatically a sudo user ( I don’t recall checking any checkbox or anything about that) because I could use sudo with my new created user.
I just remove it because I don’t like it.
I don’t know what cause that error. try install fedora in your VM environment don’t do anything fancy, just Next next next . create a user at first run, (name, password, …don’t try to find submenus about superusers), when you are setup open a terminal and just :
su -i
dnf remove sudo

if it is fedora 33, you update, restart and you may or may not be able to start Fedora depending on the last dowloaded kernel.
If you can’t start, you hit your head 3 times with your keyboard and wait for next kernel update.

I don’t see how sudo could be the problem here. Not having a root password makes the emergency shell impossible to unlock, yes, but it’s the dracut problem that’s getting us there in the first place.

It is totally unrelated indeed. I just answer to ilikelinux who were asking about that.

The first thing I would want to look at is the contents of the initramfs for a working boot vs a non working boot. It sounds like something got confused and then is being propagated forward.

sure. Please wait for couples of days, I am not at home for a while.

For the sudo user question: the live usb installation never prompted me to create a root user, it was after the installation, after the first boot I was asked to create a user.

So I was in the dracut emergency shell after failing to boot into kernel 5.10.12-200, and within the rdsosreport.txt, I could see when it was starting rule based manager and:
systemd[379]: systemd-udevd.service: Failed to execute command: Too many levels of symbolic links
and Failed at step EXEC spawning /usr/lib/systemd/system-udevd: Too many levels of symbolic links.

Shall I post the whole log, and is there anything else I should be looking for?

Yes. If you don’t have a root password set, the first user you create gets added to the wheel group, which has full sudo privileges.

On another thread in the past few days there was a conversation about broken links and how to remove them.
I ran the command to locate them and found the same “Too many levels of symbolic links.” in the output. What I found was that somehow a link had been created that pointed back to itself thus an endless loop.
These 2 commands will find and display the link with the first one and delete it with the second.

find / -type l -print
find / -type l -delete

You would want to change the start location for your needs and be careful in what you actually delete because some of those might be something you want to keep.

The link I found and deleted was like this and as you see it is a circular reference and gave that error.

lrwxrwxrwx.  1 user user     6 Feb  9 09:54 .gnupg -> .gnupg

I think possibly if you are in the emergency shell, or are booted to the live usb, that this might find that broken link and help to fix it.