Can't scan fingerprint

Can anyone please help me, I’m new to fedora and trying to add my fingerprint to the system. I go to the Settings → Users → Fingerprint Login → Scan new fingerprint → “any fingerprint” → and then system ask me to “Swipe your finger across the fingerprint reader”. I do all instructions but didn’t see the progress, all I see is when I swipe my finger the label is shaking “Swipe your finger again”, and it repeat forever.

I use: “Linux fedora 5.15.6-200.fc35.x86_64 #1 SMP Wed Dec 1 13:41:10 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux”

The hardware is ok, because previously I used Windows 10 and everything was fine.
My laptop is: Acer Swift SF314-52

When I scan USB devices (with command lsusb), I found the next one:

1c7a:0570 LighTuning Technology Inc. EgisTec Touch Fingerprint Sensor

As I understand, this device is officially supported, can anyone please tell me what I do wrong?

Have you tried just placing the finger on the reader instead of swiping?

1 Like

Yes, I tried to place it, but it works the same as a swipe. And also I tried to swipe in the different directions, this did not give any result. Every time I lift my finger from the fingerprint reader I see shaking animation of the label “Swipe your finger again”.