Can't reboot laptop when running on battery

,

I have a laptop running Fedora 39 and when I’m running on battery it frequently happens the following:

  1. Can’t reboot or turn off the laptop from the menu
  2. Wifi goes out
  3. Settings won’t open

All the other apps and things work fine. Note that this never happens when running with power connected. I disabled power saving from the settings but still happens.

I’m clueless about what the issue could be and it’s hard to find good keywords to search online. Does anybody here have any idea what could be happening?

At the moment I’m running on 6.6.13-200.fc39.x86_64 but I have been having this problem for a while (it probably started happening at some point when I had fedora 37 or 38).

I can add more details about my system if it’s helpful.

Next time try reboot from the command line and see if any errors are printed.

sudo reboot

Also you can look in the journal to see if there are logs of errors whwn you start to shutdown.

sudo journalctl --since=hh:mm

Where hh:mm is the time just before you did the reboot command.

The sudo reboot command freezes when this happens.

The journalctl command gave me some info to start reserching.

Feb 09 17:45:22 localhost.localdomain kernel: iwlwifi 0000:00:14.3: Microcode SW error detected. Restarting 0x0.
Feb 09 17:45:22 localhost.localdomain kernel: iwlwifi 0000:00:14.3: Start IWL Error Log Dump:
Feb 09 17:45:22 localhost.localdomain kernel: iwlwifi 0000:00:14.3: Transport status: 0x0000004A, valid: 6
Feb 09 17:45:22 localhost.localdomain kernel: iwlwifi 0000:00:14.3: Loaded firmware version: 77.206b0184.0 QuZ-a0-jf-b0-77.ucode

Thanks

When this happens do sudo systemctl list-jobs to see what is going on.
There should be a number of stop jobs running.
And I am guess one of them will be stuck.

1 Like

sudo and su also freeze, actually the whole system kind of goes down.

I wonder if there is some form of remediation, at least to let me soft reboot or keep using the system without wifi…

This not a normal failure mode. I wonder if you are looking at a hardward issue.

When on mains power everything works all the time?

yes, on power I use it to work for hours without issues, on battery it varies, sometimes it dies in 5-10 minutes, sometimes it could last one hour or more.

Is the battery failing?

I don’t think so

This is typical of a battery nearing the end of useful life. Older laptops could often continued working with nearly dead batteries, but many recent laptops won’t run with marginal batteries – I assume the power supply can’t meet peak demands without the help of a good battery.

The wifi is crashing but the laptop continues to work (with generalized software failures), if the wifi doesn’t crash the laptop continues to work for several hours on battery.

I had it on battery for 30-40 minutes already without issue and upower reports normally. The battery is at 63% life because the laptop is 3 years old, but it charges and discharges normally.

$ upower -i /org/freedesktop/UPower/devices/battery_BAT1
  native-path:          BAT1
  vendor:               MSI
  model:                BIF0_9
  power supply:         yes
  updated:              Sun 11 Feb 2024 07:27:21 PM CET (2 seconds ago)
  has history:          yes
  has statistics:       yes
  battery
    present:             yes
    rechargeable:        yes
    state:               discharging
    warning-level:       none
    energy:              26.4936 Wh
    energy-empty:        0 Wh
    energy-full:         32.2088 Wh
    energy-full-design:  50.008 Wh
    energy-rate:         23.3472 W
    voltage:             14.878 V
    charge-cycles:       N/A
    time to empty:       1.1 hours
    percentage:          82%
    capacity:            64.4073%
    technology:          lithium-ion
    icon-name:          'battery-full-symbolic'
  History (rate):
    1707676041	23.347	discharging
    1707676030	0.000	discharging