Can't play video in different browsers on Fedora 37

I cannot play videos under Fedora Linux 37 in different browsers (I tested Firefox, Brave, Tor) or a few frames move and after a second nothing runs anymore. I don’t get an error message. I have already deactivated add-ons such as NoScript. It didn’t matter if it was playing videos on Invidious (YT), streaming services, or other sites.

I installed all the openh264 stuff and tested with the Simple RTCPeerConnection Video Test, output: Failure callback: “The request is not allowed by the user agent or the platform in the current context.” Any ideas?

From the bit that I can find, it seems like that error usually comes about when the browser is denied some system permission that it is set up to require - either access to some part of the file system, or to some peripheral.

For the browsers that you’ve installed, are they all RPM distribution packages, all Flatpaks, a mix? For any Flatpaks, any messing around with Flatseal that you know of? Just trying to think of anything that might make system access funky?

I use Firefox (RPM) and also tried Brave (Flatpak) again. On both still the same problem. Locally on VLC videos are working totally fine…

Strange - do you find the same thing when you try in Firefox, booting from a live USB stick?

Did not try that but I fixed it. I use a simple USB-soundcard and I removed that and plugged it back in and the video played. Thanks for your help!