Can't play many Youtube videos, playing erorr Bla Bla

Hi all,

Many youtube video not working with me,I already did clean install, reset firefox, remove all addons but still the same problem, any ideas to fix this problem please?

Might need codecs,

You can install them individually or I’ve found it easier to install ffmpeg, or vlc (dependencies)



Thanks @grumpey I did all but still the same problem:

Does this help?

Thanks @ersen I already have ffmpeg


Try and install chromium-freeworld to see if it’s Firefox or maybe something else?

Maybe some other things to try:

You could also try creating a new user and see if it works under that.

1 Like

Thanks @grumpey I did also a clean install for my PC, videos are working on Chromium but on Firefox not, on Arch and windows videos work on Firefox, I don’t know why Fedora developers play a lot with Fedora browser, Chrome and Chromium I see "Managed by your Org.) Why not they use just pure browsers without touching it?

This is my question solved, it maybe useful.


Install UnitedRPMs… next.

dnf clean all && dnf -y update

I can confirm that the RPMFusion packages are enough and work well. So, this is related to the users’s configuration somehow. Best to create a new Firefox profile etc. to try and diagnose the issue.


I don’t know why Fedora developers play a lot with Fedora browser, Chrome and Chromium I see "Managed by your Org.) Why not they use just pure browsers without touching it?

If you scroll to the bottom of the article it explains what has been done.

Some other things to try:
Can you try installing mozilla-openh264
sudo dnf install mozilla-openh264
you’ll have to log out and back in after install for it to take affect
you can install the firefox update following the instructions here

If you are running Gnome on Wayland could you try doing an X11 session
or starting firefox without wayland support.


Since you did a clean install you might want to consider filing a bug noting your hardware.


1 Like

Thanks again @grumpey I am a normal user and I don’t have a lot of Tech info, I runaway from windows because of privacy concerns, for me I don’t want extra suspicious features like single sign in bla bla bla and I will never believe

Fedora will never monitor your browser activity or restrict your actions

, If I want like these services I can buy a Mac or install windows, I need simple OS and independent apps and services.

The problem fixed by installing Firefox from and not + installing VLC or FFmpeg.

Thank you again and thanks for everyone helped me :heart: :heart: :heart:


Uh, so the issue here is with the Flatpak from the Fedora Flatpak registry (which I thought was generated from the RPM itself?). If anyone else is using it, please confirm and file a bug.

1 Like

Fedora’s Firefox flatpak has issues with playing videos the last time I tried it. I assumed OP was using RPM. I am not sure if it is a bug or because of same issues why certain codecs/apps are not included in Fedora’s repos but shipped in RPMFusion. Firefox from Flathub is OK though.

1 Like

It probably is related to the flatpak not using things shipped in RPMFusion. Given that both are shown in Gnome-software etc., I think there should at least be some indication somewhere that clearly tells the user not to use the Fedora Flatpak if they intend to watch videos etc.



1 Like

Apologies for the late reply.

I actually suffered from the same problem till a guy on the internet help me fixed the same. The problem only arose in Firefox and Firefox Developer Edition.

My problem was fixed after running the following commands:

sudo dnf install$(rpm -E %fedora).noarch.rpm$(rpm -E %fedora).noarch.rpm

sudo dnf install ffmpeg-libs

I hope this helps.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.