Can't Log into Fedora anymore as admin user and also root

I was shutting down and as it was taking a while, i forced it to shutdown (bad idea in retrospect).
Upon starting up, I get the error

Cannot open access to console, the root account is locked.

I follow @nightromantic’s solution here but instead of using a fedora live disk, i used an ubuntu 18.04 live disk and reset the root password.
Now it boots up to the Login Page but can’t Login for both my initial admin user and root, I also can’t login using the terminal.

I have also tried to rename .local and .config folders but no luck.
Help Please!!

if you actually reset the root password, then you should have access to root at least

I felt so too but, that is not the case. Maybe i should mention that while following the steps here and required I skipped step 6

Try this:

Don’t miss steps

Thanks so much, am in as root and also as the admin user
Its asking to set up the desktop afresh, I suspect that’s because i renamed .local or .config.
Will revert those changes.
I’m truly grateful

1 Like

Awesome … don’t forget to tick/mark the post that solved your problem so that others will similar issues can find it.

Enjoy Fedora!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.