Cant launch wildrig multi miner on fedora 38 beacuse it doesnt recognise my supported graphics card

I cant start crypto mining in wildrig-multi-linux-0.36.6b on my amd rx580 2048SP 8GB graphics card because it says that it failed to find unsupported AMD/NVIDIA devices, but short time ago before i switched from ubuntu to fedora 38 miner worked perfectly, so that mean my GPU is supported by wildrig (thats also written in official documentation [GitHub - andru-kun/wildrig-multi: multi algo miner for AMD & NVIDIA]). Before i started to mine on ubuntu i ofc installed manually amd non-pro driver and, rorc and legacy opencl. As we know fedora kernel already contain installed amd driver, so that means theres no repo for fedora and amdgpu-install wont work on it. Also theres no rocr and legacy opencl on fedora instead theres a simple one and Mesa that i installed (They also dont solve the problem). When i found that theres more one rocm opencl that is contained in amd pro driver i sure tried to installed it but i couldnt because it require dependencies such as: comgr(rocm) 5.4 ; ; I really dont know how to install them because consider that im still a begginer in linux, so if u know exact solution to my problem please help me, id be very thankful!

P.s dont forget to check screenshots