Can't install software with gnome software

Also check this:

systemctl --failed
rpm -q -a gnome-software\* PackageKit\* polkit\* | sort
sudo rpm -V -a gnome-software\* PackageKit\* polkit\*

And perform that:

1 Like

But my goal was to issue a command that normally would pop up a window asking for the password. This in order to understand if the problem is limited to gnome-software or if it is extended to the whole polkit (or whatever).

In addition to the two log messages you posted, are there other ones (related to polkit) before these?
What happens (just for testing purposes) if you create a new user and you try with it?


ok so

does it trigger the prompt for the password

the result for this is


the result for this

it’s just nothing, meaning that when i enter the password i just get another terminal line to input a new command

i’ll try the new user in the meantime

anyway there’s clearly more cause my browser is not able to save passwords anymore…


Which browser?

using vivaldi here…i’ll try with eolie or epiphany but i’m guessing i will have the same result…

Doesn’t Vivaldi use a built in system to store passwords?

don’t really know, but i’m guessing it’s using the usual gnome keyring

anyway the new user has the same issue…

tried also with eolie and epiphany and they are not able to save my passwords so must be something system wide, or anyway connected to the keyring…

tried, that was not the solution…

1 Like

Some more log?
journalctl -b | fpaste
(Even if it could be a lot of stuff, due to -b print all the logs since the last boot)

1 Like

Log close to when the action occurred?

Hi Luca,
Just curious: if you go to Settings (cog right corner) → Users → [username who wants to install software with gnome software], is that user administrator? If not, make it; if so, try ‘on-off’-action.

Maybe you just should remove ~/.local/share/keyrings/login.keyring (or better: make backup of it) and logout and login again. This should generate a new key, see

1 Like

done and rebooted, seems that it has not created a new one…

weirdly enough, in this log the thing started working again, i absolutely don’t know why

but then i rebooted and everything is not working again

here’s the non working state log

Just to compare with my system, what are the results of these commands?
pkaction --action-id org.freedesktop.packagekit.package-install --verbose
pkaction --action-id org.freedesktop.packagekit.package-remove --verbose

And, after you have started gnome-software and tried to remove/install a package
pkcheck --list-temp

In addition, could you paste the content of /etc/polkit-1/rules.d directory?
sudo find /usr/share/polkit-1/rules.d -type f
or simply
sudo ls -la /usr/share/polkit-1/rules.d

And also
sudo find /var/lib/polkit-1 -type f

ok let’s start

the result from


description: Install signed package
message: Authentication is required to install software
vendor: The PackageKit Project
icon: package-x-generic
implicit any: auth_admin
implicit inactive: auth_admin
implicit active: auth_admin_keep

and remove

description: Remove package
message: Authentication is required to remove software
vendor: The PackageKit Project
icon: package-x-generic
implicit any: auth_admin
implicit inactive: auth_admin
implicit active: auth_admin_keep
annotation: org.freedesktop.policykit.imply → org.freedesktop.packagekit.package-install

the result from

is absolutely nothing

the result for


totale 44
drwx------. 1 polkitd root 572 19 ago 11.18 .
drwxr-xr-x. 1 root root 28 3 giu 14.29 …
-rw-r–r–. 1 root root 443 18 lug 22.00 11-fedora-kde-policy.rules
-rw-r–r–. 1 root root 1091 14 ago 09.36 20-gnome-initial-setup.rules
-rw-r–r–. 1 root root 281 15 gen 2021 50-libvirt.rules
-rw-r–r–. 1 root root 488 2 apr 11.59 gnome-control-center.rules
-rw-r–r–. 1 root root 182 2 feb 2021 org.a11y.brlapi.rules
-rw-r–r–. 1 root root 369 26 gen 2021 org.freedesktop.bolt.rules
-rw-r–r–. 1 root root 769 15 lug 10.03 org.freedesktop.Flatpak.rules
-rw-r–r–. 1 root root 252 30 lug 14.47 org.freedesktop.fwupd.rules
-rw-r–r–. 1 root root 257 30 lug 10.24 org.freedesktop.packagekit.rules
-rw-r–r–. 1 root root 590 30 apr 13.19 org.gtk.vfs.file-operations.rules
-rw-r–r–. 1 root root 527 6 ago 16.42 systemd-networkd.rules


is absolutely nothing again…

Sorry @luca247 if I iterate around many requests, but it is not simple to troubleshoot an issue like this. Also because it never happened to me. I’m only figuring out if something could help us to identify the issue.
What is the result of this command?

pkcheck -p `pidof gnome-software` -a org.freedesktop.packagekit.package-remove -u

On my system, the window asking for the password pop up.

In addition, I’ve seen that GNOME Web doesn’t save passwords if the login keystore doesn’t exist. And again, I’m pretty confident that Vivaldi uses its own keystore (like Firefox does). So I suspect that these other issues are unrelated. But who knows, I’m a simple user like you.

1 Like

same as you, password prompt…

firts of all, looking at your journalctl output, it is safe to remove /etc/rc.d/init.d/livesys-late (saves a log message - see entry ‘992’)

But that’s not really important now - i see a lot of gnome-shell errors, mayby reinstalling gnome-shell should kick something in the right direction?

edit: looking at your log, i remember why i disabled audit on my system: it is a log spammer. For a more readable log you could add audit=0 at the kernel command line in grub before booting. Reading your log there is a lot going on on your system, maybe try to disable some unwanted services with systemctl will make it better. Certainly remove the livesys-late, i saw it wants to start (through systemd) app-glib-liveinst\x2dsetup and fails.
But that log is hard to read, Otherwise try something like sudo journalctl -b | grep systemd to just get the systemd records and | grep gnome for output gnome related

Hello everybody,

I had created a ticket on the fedora bugzilla and luckily some dev helped me solve the issue

If you want to have a look the fix (and the discussion) is here


just a quick update to say that fix will be included soon in regular updates :slight_smile:

1 Like