Can't install fedora 31

Hello Everyone,
Newbie here trying to install Fedora 31 on desktop but running into issues. My hardware:

Motherboard: Asus Hero XI Maximus
CPU: Intel I9 9900K
GPU: Nvidia 2080 TI RTX
Harddrive: Sumasung m.2 nvme 1 tb
Ram: 32 gig 3200mhz

I am trying to install Fedora 31 from USB, and as I click on install, I see a few lines running and saying ok in green color and then the screen goes black with pixels and nothing happens for hours and have to force restart everything.

I could not get anything installed and have no OS currently, any suggestions as what to do.

Thanks for your help in advance.

It sounds like a graphic driver issues to me.

Will you consider doing the installation in Text Mode?

Thank you for the response. If I go ahead with text mode installation, will I be able to have dual booth or not.
Also will the system install automatically or do I need to do partitions myself.

Sorry I am new at this and want to know what I am doing and the steps.

If you are new to installing Fedora, then doing it via the GUI is much better. The Text mode interface should offer the same function as the GUI mode interface.

Can you do an installation in a virtual guest to get familiar with Fedora installation first?

Long time ago, I tried once that Fedora Installer can:

  • reduce size Windows partitions
  • create partitions for Fedora
  • configure Dual-boot between Windows and Fedora

This is a Multi-boot guide and this is how to reclaim disk space using the GUI installer

Although the versions covered are old, the concepts and overall methods still apply.

Thank you SampsonF, I will try it tonight and update the post if I run into any issues.

1 Like

Just a note that this link is for Fedora 25, not a current release (F30/F31). Instructions there may not work, so please tread carefully.

1 Like

Welcome to edora, @msultani! Please take a look at the posts in the #start-here category if you’ve not yet had a chance.

Can you clarify what stage of the installation process this is? You’ve selected “install Fedora”, and that opens up the Anaconda installer. Then you have selected the disk and network and so on on clicked “install”? What are these few lines? There should only be one “progress bar”. Can you upload a picture please?

If that is the case, it is not necessarily a graphics issue. If it were a graphics issue, the live media would likely not have got you this far. This could just be an Anaconda bug. Hard to say at the moment.

My first suggestion would be to try an updated ISO image that the community generates. You can get your flavour of choice here:

1 Like

Unfortunately I could not install it. I decided to install windows and allow 100 GB for Fedora. And when I select custom, I have to do my own partitions, which I am afraid, as I dont know what I am doing.

Well noted.

This will be very helpful to the community members.

Sure, but we need more information to be able to help here. Why could you not install it? Did you get an error?

The “custom partitioning” settings can also create partitions for you automatically, using the “Click here to create them automatically” option in the top left corner. If you want partitions instead of LVM, pick “partitions” in the drop down before clicking on “Click here to create them automatically”:

I can not even get to that part. This what happens and I found the issue:

  1. The problem is the Nvidia drivers. I can not even boot to install screen.

  2. My system use uefi (might be an issue)

  3. Even the safe mode takes me to black screen

This is why I can not install anything.


I think that it can be due of your intel (CPU+GPU) and the nvidia GPU which sometimes did show problems between the intel driver and the nouveau driver.

You can try do the steps that I will post below or wait for another suggestions from more experienced users because i never did run in this problem so I couldn’t text this for myself.

Before you do push in the option to install, highlight this line and push the key e so that you can have access at kernel where you should move down until a line called linuxefi/linux where you would add nouveau.modeset=0 to the end of the line (so called you did add a extra argument/parameter) - press F10 to boot. If it was the problem you should can run the installer in GUI mode, If it run well and you did a right installation in the next reboot you will see the entries to run fedora, windows… If you push fedora this should not start to due the same problem, so you would need highlight the fedora entry and push the key e again and do the same step one time more.

After that you did it you would go into the fedora desktop and install a package called grubby

Open a terminal and run this command

sudo dnf install grubby

Now lets add nouveau.modeset=0 parameter to the kernels argument in the Grub.

sudo grubby --update-kernel=ALL --args="nouveau.modeset=0"

Now let’s check that this parameter was really added in the args in your actual kernel

sudo grubby --info /boot/vmlinuz-$(uname -r)

Now you should can run fedora in the following reboots, but you should want install the private driver of Nvidia what you can do in a easy way in fedora:

if you look in the forum through the search option with the words “install nvidia driver you” should find it.

I will add here (below) some links of interest from sites where I did take information.


I would try booting Fedora Live, you will see if there is any problem with your HW without having to bother with installation.
Choose your preferred GUI among the LIVE ISOs at

Hello, I have the same trouble as yours. Have you solved the problem? My laptop is HP OMEN 15 dc0xxx, and yes, it cannot enter into the installation interface. The screen just outputs some rubbish after some readable “[OK]” lines.

Hello, I think that I have the same problem as him.
My laptop is HP OMEN 15-dh0xxx with Intel i7-9750H, NVIDIA RTX2060, Samsung SSD 512GB. The F31 USB live stick was burned by official Fedora Media Writer. In UEFI mode, security boot turned off, after I choose the boot menu “start fedora 31 live …”, the screen just outputs some pixel rubbish after a few readable “[OK] …” lines.
I tried the grub boot command “nouveau.modeset=0”, and the rubbish was gone, but after some “[OK] started …” lines, everything went to “[OK] stopped …”. At the end, the infinite “ACPI ERROR: …” loop lines followed behind.
Please help!

If there is a problem with the graphics card, the installation process may hang due to anaconda.

In such a case, there is a way to install the operating system with the cpu built-in graphics after removing the graphics card and to solve the graphics problem through the nvidia driver after allowing remote access ssh or telnet.

The installation process does not proceed when a normal graphics problem occurs, so you may want to consider just another method. Have a nice day!

try add also this parameter too in the boot proces

Edit: if the parameter above doesn’t work you can try with this 2 (not sure it will change anything)

noapic acpi=off


Thanks for your reply! But it’s still not working. :frowning_face:

With only acpi=off, what I got is just a black screen. After a few minutes wait, it’s still nothing.
And, it is the same as with both noapic and acpi=off.

With only noapic, what I got is seemly a kernel panic below.

1 Like

Check this bug

It should be the reason

1 Like

Is there a graphic part selected in the BIOS setup part? Some high-performance laptops have a choice of graphics.