Can't install any plasma addons


Whenever I try to install any plasma add-on, through discover or through settings, I get the error message error: SETTINGS invalid number of concurrent streams. I can install other packages just fine. Also, I have reinstalled linux, and the issue persists.
Here is the full error from discover:

org.kde.plasma.libdiscover: last stream isn't over yet Filters(category: Category(0x559fa59cbe00, name = "Plasma Addons"),search: "ant-dark",) ResourcesProxyModel(0x7f600c0b51f0) connection error: SETTINGS invalid number of concurrent streams stream 1 finished with error: "SETTINGS invalid number of concurrent streams"
kf.newstuff.core: "SETTINGS invalid number of concurrent streams"
kf.newstuff.core: "Download of \"Ant-Dark KDE\" failed, error: SETTINGS invalid number of concurrent streams"
KNS error in "Global Themes" : KNSCore::InstallationError "Download of \"Ant-Dark KDE\" failed, error: SETTINGS invalid number of concurrent streams" QVariant(Invalid)
kns error "/usr/share/knsrcfiles/lookandfeel.knsrc" "Download of \"Ant-Dark KDE\" failed, error: SETTINGS invalid number of concurrent streams"

Thanks for any help!

EDIT 1: I have tried to install a plasma theme on a live ISO, on mine and a friends computer. In both cases the same error appeared. I have tested the ISO media in both cases.
EDIT 2: I have reinstalled and tested the live ISO, issue still persists. Could it be possible that the issue is server-side?
EDIT 3: I have connected to the internet through my phone hotspot. Still the same error. No idea what to do.

Did you look into your dnf configuration?

sudo nano /etc/dnf/dnf.conf

Mine has these entries under


Mine looks like this:

# see `man dnf.conf` for defaults and possible options


I’ve tried adding max_parallel_downloads=10 but it didn’t work.


I’m having the exact same issue and not found a solution. Also not found many other reports of this anywhere either so not sure what to do.

I tried all the same steps as OP, and also tried different KDE flavoured Live ISOs (Manjaro and arco) and same issue.

Using Fedora 36, and started happening yesterday afternoon (now morning where I am).

Found one report of it on the KDE forums, but no replies so far. Feels like it might be server side, but any suggestions would be hugely appreciated.


You could try this, maybe it helps:

dnf grouplist -v

and then

sudo dnf install @kde-desktop

or alternatively:

sudo dnf install @kde-desktop-environment

Just a try that couldn’t hurt anything… (see here).

Also, take a look at this:



When enabled, DNF will save bandwidth by downloading much smaller delta RPM files, rebuilding them to RPM locally. However, this is quite CPU and I/O intensive. Default is True.



When the relative size of delta vs pkg is larger than this, delta is not used. Default value is 75 (Deltas must be at least 25% smaller than the pkg). Use 0 to turn off delta rpm processing. Local repositories (with [file://](file:///) baseurl) have delta rpms turned off by default.


So you could try disabling deltarpm, perhaps.

Are you able to use dnf in the terminal and can you update the system with dnf.
sudo dnf upgrade --refresh
I’m pretty sure Discover does not use dnf.

It seems there is a bug in Plasma so I’m guessing there should be an update soon.

1 Like

I concur. I’m also having the same issue.
Hopefully KDE 5.25 will be pushed to Fedora repositories soon.

Can confirm. I have this issue too.

It looks like the issue is caused by a bad update. Hopefully it gets fixed soon.

For those interested.

Thanks for that.
Looks as if it isn’t fixed in KDE 5.25 either based on the last post from 4 hours ago of a user getting the same error in 5.25.

I have installed the dnf group “kde-desktop” two times over the last three days on two different machines, without any issues. Installing add-ons was no problem on either one.

(See my post above.)

Thanks for the suggestions ivanhoe. I ended up just opening a KDE bug report and can confirm what Joe says. They mentioned those links detailing the issue as well as a “possibly related merge request” as they phrased it:

So hopefully that fixes it! Doesn’t seem to be affecting everyone.


Same issue here. dnf through konsole updates, but if i try to download software through discovery or add ons, it gives me the too many streams error. Hope it gets fixed soon

This appears to be a QT bug that will be fixed in the next update. I’ve seen this problem mentioned across multiple distros with KDE/ Plasma.

I`m trying out Fedora36 it wored fine in KDE about 3 weeks ago. Today, I made a fresh install perhabs to use it as my daily driver -plasma addons not working. I also used the ISO which I downloaded 3 weeks ago and tried if it works with no Sys upadtes same error.
I use Arch too on a Laptop with KDE 5.25 no issue at all works fine.

KDE have updated the bug report confirming the fix is in Qt 5.25.1 for anyone interested.


@eskay993 Thanks a lot, so it will working soon again.