Can't get required rpm fusion drivers

sudo dnf list modular --recent
Last metadata expiration check: 0:30:36 ago on Sun 30 Apr 2023 04:58:09 PM.
Error: No matching Packages to list

Frustrating, but let me search a moment.

Yes very frustrating

First try dnf module list to see what that may show.
If it gives you a response then we can disable it.

sudo dnf module list
Last metadata expiration check: 0:40:06 ago on Sun 30 Apr 2023 04:58:09 PM.
@modulefailsafe
Name                                       Stream                                       Profiles                                     Summary                                                          
nvidia-driver                              latest-dkms [e]                              default, fm, ks                              Nvidia driver for latest-dkms branch                             

Hint: [d]efault, [e]nabled, [x]disabled, [i]nstalled

Now we are getting somewhere.
dnf module disable nvidia-driver

sudo dnf module disable nvidia-driver
Last metadata expiration check: 0:42:18 ago on Sun 30 Apr 2023 04:58:09 PM.
Dependencies resolved.
======================================================================================================================================================================================================
 Package                                         Architecture                                   Version                                         Repository                                       Size
======================================================================================================================================================================================================
Disabling modules:
 nvidia-driver                                                                                                                                                                                       

Transaction Summary
======================================================================================================================================================================================================

Is this ok [y/N]: y
Complete!

Follow that with the dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda

sudo dnf install akmod-nvidia xorg-x11-drv-nvidia-cuda
Last metadata expiration check: 0:43:58 ago on Sun 30 Apr 2023 04:58:09 PM.
Dependencies resolved.
======================================================================================================================================================================================================
 Package                                                Architecture                    Version                                        Repository                                                Size
======================================================================================================================================================================================================
Installing:
 akmod-nvidia                                           x86_64                          3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                           40 k
 xorg-x11-drv-nvidia-cuda                               x86_64                          3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                          1.8 M
Installing dependencies:
 egl-gbm                                                x86_64                          1.1.0-3.fc37                                   fedora                                                    20 k
 libglvnd-gles                                          i686                            1:1.5.0-1.fc37                                 fedora                                                    30 k
 libglvnd-opengl                                        i686                            1:1.5.0-1.fc37                                 fedora                                                    40 k
 nvidia-persistenced                                    x86_64                          3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                           35 k
 nvidia-settings                                        x86_64                          3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                          1.7 M
 opencl-filesystem                                      noarch                          1.0-16.fc37                                    fedora                                                   7.4 k
 xorg-x11-drv-nvidia                                    x86_64                          3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                           42 M
 xorg-x11-drv-nvidia-cuda-libs                          i686                            3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                           55 M
 xorg-x11-drv-nvidia-cuda-libs                          x86_64                          3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                           54 M
 xorg-x11-drv-nvidia-kmodsrc                            x86_64                          3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                           45 M
 xorg-x11-drv-nvidia-libs                               i686                            3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                           29 M
 xorg-x11-drv-nvidia-libs                               x86_64                          3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                          186 M
Installing weak dependencies:
 xorg-x11-drv-nvidia-power                              x86_64                          3:530.41.03-1.fc37                             rpmfusion-nonfree-nvidia-driver                          199 k

Transaction Summary
======================================================================================================================================================================================================
Install  15 Packages

Total download size: 415 M
Installed size: 1.1 G
Is this ok [y/N]: 

Proceeding

1 Like

I’ll then wait the appropriate amount of time for things to build. Should take too long my system is a XEON with 32G of memory and all SSD’s

I am learning more about fedora and modules as I go. Mostly that I am glad I avoid them as much as possible.
Glad to be able to help.

Wait at least 5 minutes after the install completes before you reboot.

I wish I’d never even heard of them at this point :wink:

so far

sudo dnf list installed 'kmod-nvidia-$(uname -r)*'
Error: No matching Packages to list

but after the install I got

You should restart:
  * These applications manually:
      firefox
      thunderbird
      xdg-desktop-portal-gnome

Additionally, there are:
  - 1 processes requiring restart of your session (i.e. Logging out & Logging in again)

For more information run:
    sudo tracer -iat 1682890925.26072

When fedora made the fedora modular repos (years back) I immediately disabled them, and had to repeat that with each upgrade.

I see that with a clean install of fedora 38 the fedora-modular and updates-modular repos are disabled by default. Glad they finally did that.

Your issue though was not caused by the fedora main repos, but the fedora-cuda repo. I have seen many issues with modular conflicts caused by installing packages from that repo.

I see, lucky me

Wait another minute or so and get the return for the dnf list installed 'kmod-nvidia-*' package before you reboot.

We all learn from trial & error, and there are many posts recommending that site. (unfortunately)

sudo dnf list installed 'kmod-nvidia-*' 
Error: No matching Packages to list

try ps aux | grep akmod. If that returns anything except a single line with that exact command then it is still building the modules.

ps aux | grep akmod. 
vstubbs  3281081  0.0  0.0 222156  2176 pts/0    S+   18:06   0:00 grep --color=auto akmod.