Can't get past credentials screen, goes black and freezes after entering login info. Issue persists across users, kernels, and a new installation

While playing a game a few days ago, steam crashed my computer. It then rebooted into grub, where I then booted into fedora 38, with the default kernel. After entering my encrypted LUKS password, I then tried to login as myself. After I (correctly) enter my credentials, it goes to a black screen and disconnects from my bluetooth speaker. I have tried rebooting into different kernels, and entering different users. Each time, the same problem follows me. I’ve been able to enter into different users, but it’s always the same thing with my user, and eventually the other users encounter the same problem. This bug has followed me to no end.

I even completely flashed a new version of fedora 38, yes a complete re-install, and even it didn’t work; eventually succumbing to the same glitch. I’m fresh out of ideas, and at the limits of my patience with this.

My hardware: AMD Rx 5700xt, AMD Ryzen 5600g, random realtek wifi chip, and a broadcom wifi chip from an old mac.

Fedora is Fedora 38 with KDE. It’s pretty vanilla, since this problem PERSISTS across different installations, users, and kernels.

Please help. I’ve never seen anything like this before. I use fedora on my corebooted chromebook that has the most random, proprietary hardware and spews errors out the ass, and it works better now than on my desktop. I have no idea what the problem might be, I’ve even gone into the command line mode and created new users, just to login as them and try again. The same thing happens. I can dump logs, do whatever, but can someone please help? Thanks for making it through this wall of text.

To summarize:
-persists across kernels, users, and a new installation
-can be averted temporarily, by creating new users, but eventually happens again, usually after playing a game on steam on installing a new application
-It keeps happening. Over, and over, and over again. I think it must be something with my hardware? Some random bios setting? I’ve reset my bios, and my hardware is just a generic AMD build.
-fedora seems to work literally anywhere else but my computer. I’ve never had any problems like this before.

edit: just did a full re-install, but installed to a usb stick instead of a normal drive. It fails too, so if anyone want’s it as a .iso file, you can have it.

Can you ssh into the computer from another?
Can you use ctrl-alt-f3 to get to a login prompt?

The info to understand this can then be collected from journlctl, dmesg etc

I wonder if you have failing hardware.

Trigger the problem (log in to a black screen). Wait a while. Switch to a TTY (Ctrl+Alt+F3 for example), log in, collect journal (sudo journalctl -b > journal.txt) and paste a link here.

Also download memtest, burn to a flash drive, boot from it, and let it run throughout the whole night. There mustn’t be any errors.

In your desktop session, run prime95 in a torture test, and let it run throughout the whole night (that would be a second night). There mustn’t be any errors.

Just switched to a text interface, and successfully logged in. I don’t know how to export this log off device, so If you have a way I’ll do it and link it here. I’ve tried logging in with secure boot turned off, and with both wayland and x11. I’ve also updated/reset my bios, and then turned on/off secure boot. I also turned on legacy bios mode, which also didn’t work. Fast boot is off, xmp is off, and all settings are at their defaults. I’ll run prime95 as soon as I can figure out how to do so via terminal interface, alternatively I could re-install which seems to stave off the problem for a while. I suspect it could be some hardware problem, possibly my RAM, because in memtest it says DDR4 2133, when it’s actually DDR4 3200.

edit: memtest gives me a pass

edit2: I have the log, this is it here:, the kernel is 6.2.something, but this is just one of many I’ve tried to use. In GRUB, this is the one labled recovery. The jorunalctl log is here Sep 27 20:50:43 fedora kernel: Linux version 6.2.9-300.fc38.x86_64 (mockbuild@38 -

Terminal interface is working, and I can log in. I’ve updated everything I can with dnf, but the problem persists. I’ve also tried different combinations of my discrete AMD 5700xt and my APU, neither of which yields different results.

I did not spot anything in the system journal (may have missed something).

What does the user journal contain after the failed login?

journalctl —user -b 0

If you can log in via the terminal, run df -h and see if any of your file systems are at 100%.

Hello @goryramsy ,
I took a look through your pastebin log and this line at the top stuck out to me…


Are you currently booting into the rescue option of your Grub menu? If you can, try to get the Grub menu up at boot (press and hold space before Fedora loads) and select the latest kernel you have installed to boot. Then the log will be needed again. You can also use the install media and try to repair an existing system from the troubleshooting option of the boot up menu provided by the installer. It may require the “everything” iso.

Yes, I am booting into the recovery one. The same issue persists throughout each kernel, and I chose the recovery one for this log gathering on the assumption that it would have more verbose logs. I’ll try your idea about the recovery image from an ISO install media. Thanks!

As far as I can tell, none of them are. It’s also a relatively fresh install, as I had just re-installed because this problem keeps happening.


I just completely re-installed a new system, deleted all my prior data, and the problem persists. I also did a disk check on every part of my ssd’s, and they’re all fine. It ran prime95 at torture mode successfully as well, so I doubt it’s a hardware problem.

Please post the output of df -h for us to look at. That comment implies you are not 100% certain of what you see.

I know how to check image sizes. The largest disk utilization is 38% in the boot partition. It’s not a disk image space, as this issue has happened when creating new installs, one of which I created a few hours ago.

Hello @goryramsy ,
Does the installation (new one you tried) make it all the way to the point where it writes the grub menu then fail?

It works and it installs completely. After using it for a few days, it will crash and then no longer get past the login screen. As far as I know, there are no issues with grub. I can get to a terminal interface by using a keyboard shortcut on the screen before it crashes. Running the plasma-startwayland command or the start x11 command don’t fix anything either.

So if you can boot after the crash then you should be able to look at the log journals to try to troubleshoot this. journalctl -b -1 --priority=3 will give you the boot errors for the previous boot.

I wasn’t concerned with the utilization of /boot. Having /, /home, or /var at 100% utilization can cause similar issues. Also use the -i option to check the inodes usage while you’re at it: df -hi