Can't find installed package for removal

Hi there,

I’m using Tracktion Waveforms for cutting audio.
A few years ago I installed Waveforms 11 but I don’t know how, I think via RPM Package, which I converted with alien.

Anyways, I wanted to uninstall it, because I have installed Waveform 12, but I cant find the package.

I searched it with:

rpm -qa | grep -i waveform
rpm -qa | grep -i tracktion
rpm -qa | grep -i tracktion-waveform


I also tried:

yum list | grep [packagenames]


there is also no flatpack installation listed.

the weird thing is, I also cant find Waveform 12, which I previously installed a few days ago via converted rpm.

Can anyone help me please?

Thank you in advanced!

Do you still have the .rpm packages you created with alien? What does rpm -qi <filename>.rpm say?

thanks for your reply!

I only have the waveform 12 rpm.
Its marked as not installed.

I was hoping to see the full output, but in particular I wanted to see the Name field.

you may want to check
sudo dnf list installed | grep commandline

if you have the name of one of the files from the package, for example the program file, you can run rpm -qf FILENAME where FILENAME is the name of the file.
That will git you the name of the package.

the name is “waveform12”
I tried this name with above commands, but nothing.

the full output is:

Name        : waveform12
Version     : 12.5.11
Release     : 2
Architecture: x86_64
Install Date: (not installed)
Group       : Converted/sound
Size        : 165997470
License     : see /usr/share/doc/waveform12/copyright
Signature   : (none)
Source RPM  : waveform12-12.5.11-2.src.rpm
Build Date  : Do 19 Okt 2023 19:46:07 CEST
Summary     : audio and midi workstation
Description :
Waveform is a powerful workstation for audio/midi recording and editing.

thx, but theres no output…

if I do that, output is:

The file /home/…/Downloads/waveform12-12.5.11-2.x86_64.rpm is not part of a package

They meant to use rpm -qf with an installed file, e.g. /usr/bin/Waveform11 or /usr/share/applications/waveform11.desktop. Those are both actual filenames from the waveform11 deb package used as the source for the flatpak. Do those files exists on disk? If not, you probably didn’t install waveform11 as an rpm.

oh I’m sorry, I’m actually a newbe at linux…

The file /usr/bin/Waveform11 is not part of any package

The file /usr/share/applications/waveform11.desktop is not part of any package

hope that helps?

Then unless your rpmdb is corrupted (?), you must have installed it some other way.

Is it possible you used dpkg to install the .deb? While certainly not a good idea, I think it would have worked if you used whatever the equivalent of --nodeps is.

that was a good point.
I found waveform 12 with dpkg command.
but I’m sure, I converted the deb package and installed it via alien… weird.
but, there is no waveform 11 package listed, hm.

oh dear, I got it!

I think this is how I installed it:

1 Like