Can't enter in init 3 in kernel version

I can’t enter in init 3 mode in Fedora 36 with the kernel version When I try, the screen stop receiving signal from the gpu (display sleep). When I try init 3 with older version of the 5.18 Kernel, that are available in grub, I can enter in init 3 without problems.

I was thinking that this was a problem related specific to kernel, but today I update to kernel and still can´t access init 3.

Does anyone have a clue of what is happening?

edit: In case is relevant, I am using nvidia driver version 515.57 installed direct from nvidia website, not rpm fusion.

I am having the same problem, not using NVIDIA drivers, and have the same problem with .11 kernel. After multiple reboots I got in to the system, so I’m going to be careful about rebooting again as it may take multiple tries to get somewhere useful.

I’m guessing some change to GDM may be involved here.

I had a different issue (some USB devices attached to my docking station no longer appeared in lsusb), so I powered down the laptop and the dock and then powered up. The system came up with the .15 kernel and everything is working as normal. Odd.

My problem is only related to the init 3 (console mode). I can use the gui without any problem with gnome. I just can’t enter in init 3 and, therefore, update my nvidia drivers to the last version.

Ahh, sorry, I misunderstood.

No problems, at least you are able to solve your problem.

You do not need to go to run level 3 to update the drivers. I used to use the drivers from nvidia and with a kernel update I booted to the newest kernel and then did a reinstall from the .run file. Another reboot brought things up properly.

Today I use the driver from rpmfusion and the driver is automatically updated by akmod-nvidia with each kernel or driver version update. There is no need to manually update the modules.

Just another thing to be aware of.
The driver from rpmfusion (akmod-nvidia) is capable of signing the module so you are able to use secure boot. The driver from nvidia does not do that.

The problem with the nvidia driver from RPM Fusion is that it did not enable nvidia h.264 decode and encode in Davinci Resolve. I am a professional Colorist and Davinci Resolve is my main software. So, the rpm fusion version of the nvidia driver is a no go for me.

About the installation procedure, you mean just execute the run file in gui mode? I tried that and the nvidia driver refuse to install the update of the driver. I think they say the driver is already loaded and is been in use, which make sense, since X is runnig.

But what make me curios is why I am unable to access init 3 in my system? It use to work just fine.

I just tested your scenario on my new install and it worked perfectly.
from the grub boot menu I selected the kernel, edited the line beginning with linux and removed rhgb quiet and added init 3 and it booted to a text login screen at run level 3.

As far as I know there is no difference in the nvidia driver from nvidia and the one from rpmfusion other than the installation method. I do not use Davinci Resolve so I have no experience there.

Can you switch to a tty ctrl + alt + F3 or F4 or F5
login and do
systemctl isolate

or you could try
systemctl stop gdm.service

and then try to upgrade.

In kernel 5.18.15 and 5.18.13 the boot process hangs. in Kernel 5.18.11 it boot in int 3, no problem.

Unfortunately this is a problem in rpm fusion that only happen in davinci resolve studio. I think is related to the way of nvenc package in rpm fusion, but it is just a guess.

Any of the ctrl + alt + F… combinations doesn’t work in kernel 5.18.15 or 5.18.13, the screen turn black and sleep. In 5.18.11 it works fine.

Same result as trying init 3 or ctr +alt +F…, display sleep

Same result, display sleep